aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/openvpn/Makefile')
-rw-r--r--security/openvpn/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
new file mode 100644
index 000000000000..c19f50915d6b
--- /dev/null
+++ b/security/openvpn/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: openvpn
+# Date created: 2002-06-23
+# Whom: Matthias Andree <matthias.andree@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openvpn
+PORTVERSION= 1.2.1
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= matthias.andree@web.de
+
+LIB_DEPENDS= lzo.1:${PORTSDIR}/archivers/lzo
+
+GNU_CONFIGURE= yes
+USE_OPENSSL= yes
+CONFIGURE_ARGS= --with-lzo-lib=${LOCALBASE}/lib \
+ --with-lzo-headers=${LOCALBASE}/include \
+ --program-transform-name="s/x/x/"
+
+MAN8= openvpn.8
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docs in AUTHORS COPYING COPYRIGHT.GPL ChangeLog INSTALL NEWS \
+ PORTS README
+ @${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
+.endfor
+.for dirs in easy-rsa sample-config-files sample-scripts
+ @${MKDIR} ${DOCSDIR}/${dirs}
+ @${INSTALL_DATA} ${WRKSRC}/${dirs}/* ${DOCSDIR}/${dirs}
+.endfor
+.endif
+
+.include <bsd.port.mk>