aboutsummaryrefslogtreecommitdiff
path: root/security/orthrus/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/orthrus/Makefile')
-rw-r--r--security/orthrus/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/security/orthrus/Makefile b/security/orthrus/Makefile
new file mode 100644
index 000000000000..22ee0375adf2
--- /dev/null
+++ b/security/orthrus/Makefile
@@ -0,0 +1,37 @@
+# Created by: Gavin McDonald <gavin@16degrees.com.au>
+# $FreeBSD$
+
+PORTNAME= orthrus
+PORTVERSION= 0.8.0
+CATEGORIES= security
+MASTER_SITES= GOOGLE_CODE \
+ http://16degrees.com.au/${PORTNAME}/
+
+MAINTAINER= gavin@16degrees.com.au
+COMMENT= One-Time Password System (OTP) alternative to OPIE or S/Key
+
+LICENSE= AL2
+
+LIB_DEPENDS= apr-1:${PORTSDIR}/devel/apr1
+
+USE_SCONS= yes
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+USES= iconv
+PORTDOCS= *
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && \
+ ${INSTALL_DATA} NOTICE README TODO ${DOCSDIR})
+.endif
+ ${TOUCH} ${PREFIX}/etc/orthruskeys
+
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>