aboutsummaryrefslogtreecommitdiff
path: root/security/osiris/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/osiris/Makefile')
-rw-r--r--security/osiris/Makefile76
1 files changed, 46 insertions, 30 deletions
diff --git a/security/osiris/Makefile b/security/osiris/Makefile
index 028fa300bdd1..84c776696d05 100644
--- a/security/osiris/Makefile
+++ b/security/osiris/Makefile
@@ -6,46 +6,62 @@
#
PORTNAME= osiris
-PORTVERSION= 1.5.2
+PORTVERSION= 2.4.4
CATEGORIES= security
MASTER_SITES= http://osiris.shmoo.com/data/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-stable
-MAINTAINER= ecu@ipv42.net
-COMMENT= File integrity checking, with GDBM and MySQL support
-
-.if defined(WITH_MYSQL)
-LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
-CONFIGURE_ARGS+= --with-mysql=${LOCALBASE} \
- --enable-module=mysql
-.else
-LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
-CONFIGURE_ARGS+= --with-gdbm=${LOCALBASE} \
- --with-module-lib=${LOCALBASE}/lib \
- --with-module-includes=${LOCALBASE}/include
-.endif
-
-NO_CDROM= This software can not be sold.
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= The Shmoo client/server host integrity checker
GNU_CONFIGURE= yes
-USE_LIBTOOL_VER=13
-
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_LIBTOOL_VER= 15
-MAN1= osiris.1 scale.1
+DOCS= docs/OsirisUserGuide.pdf docs/OsirisUserGuide.rtf
-pre-configure:
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Set WITH_MYSQL to get MySQL support."
- @${ECHO_MSG} ""
+.if defined(WITH_OSIRISMD)
+PLIST_SUB+= OSIRISMD=""
+.else
+PLIST_SUB+= OSIRISMD="@comment "
+.endif
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/configs/osiris-freebsd-4.4.conf \
- ${PREFIX}/etc/osiris.conf-sample
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for f in docs/manual.html docs/manual.txt
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Define WITH_OSIRISMD to enable build of the management daemon."
+ @${ECHO_MSG}
+
+post-build:
+ ${SED} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/src/install/freebsd/osirisd.in > \
+ ${WRKSRC}/src/install/freebsd/osirisd.sh.sample
+.if defined(WITH_OSIRISMD)
+ ${SED} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/src/install/freebsd/osirismd.in > \
+ ${WRKSRC}/src/install/freebsd/osirismd.sh.sample
+.endif
+
+do-install:
+ ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+ @${MKDIR} ${PREFIX}/osiris/configs
+.for os in bsdos darwin freebsd irix linux openbsd sunos unix-generic \
+ windows2000 windowsnt windowsxp
+ ${INSTALL_DATA} ${WRKSRC}/src/configs/default.${os} \
+ ${PREFIX}/osiris/configs
.endfor
+ ${CHOWN} -R osiris:osiris ${PREFIX}/osiris
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/cli/osiris ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/osirisd/osirisd ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/install/freebsd/osirisd.sh.sample \
+ ${PREFIX}/etc/rc.d
+.if defined(WITH_OSIRISMD)
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/osirismd/osirismd ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/install/freebsd/osirismd.sh.sample \
+ ${PREFIX}/etc/rc.d
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>