aboutsummaryrefslogtreecommitdiff
path: root/security/osslsigncode/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/osslsigncode/Makefile')
-rw-r--r--security/osslsigncode/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/security/osslsigncode/Makefile b/security/osslsigncode/Makefile
new file mode 100644
index 000000000000..bb541aee61bb
--- /dev/null
+++ b/security/osslsigncode/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: osslsigncode
+# Date created: 9 November 2006
+# Whom: snb@threerings.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= osslsigncode
+PORTVERSION= 1.2
+CATEGORIES= security devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= snb@threerings.net
+COMMENT= OpenSSL-based signcode utility
+
+PLIST_FILES= bin/osslsigncode
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_OPENSSL= yes
+
+.if !defined(WITHOUT_CURL)
+LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
+.endif
+
+.include <bsd.port.mk>