aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Auth-YubikeyDecrypter
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-Auth-YubikeyDecrypter')
-rw-r--r--security/p5-Auth-YubikeyDecrypter/Makefile25
-rw-r--r--security/p5-Auth-YubikeyDecrypter/distinfo3
-rw-r--r--security/p5-Auth-YubikeyDecrypter/pkg-descr15
-rw-r--r--security/p5-Auth-YubikeyDecrypter/pkg-plist5
4 files changed, 48 insertions, 0 deletions
diff --git a/security/p5-Auth-YubikeyDecrypter/Makefile b/security/p5-Auth-YubikeyDecrypter/Makefile
new file mode 100644
index 000000000000..d404e88d221e
--- /dev/null
+++ b/security/p5-Auth-YubikeyDecrypter/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Auth-YubikeyDecrypter
+# Date created: Jul 2, 2010
+# Whom: Kurt Jaeger <fbsd-ports@opsec.eu>
+#
+# $FreeBSD$
+
+PORTNAME= Auth-YubikeyDecrypter
+PORTVERSION= 0.07
+CATEGORIES= perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/M/MA/MASSYN
+PKGNAMEPREFIX= p5-
+DISTNAME= Auth-Yubikey_Decrypter-${PORTVERSION}
+
+MAINTAINER= fbsd-ports@opsec.eu
+COMMENT= Decrypting the output from the yubikey token
+
+RUN_DEPENDS= p5-Crypt-Rijndael>=1:${PORTSDIR}/security/p5-Crypt-Rijndael
+
+LICENSE= GPLv2
+PERL_CONFIGURE= yes
+
+MAN3= Auth::Yubikey_Decrypter.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Auth-YubikeyDecrypter/distinfo b/security/p5-Auth-YubikeyDecrypter/distinfo
new file mode 100644
index 000000000000..799e2ea6eed5
--- /dev/null
+++ b/security/p5-Auth-YubikeyDecrypter/distinfo
@@ -0,0 +1,3 @@
+MD5 (Auth-Yubikey_Decrypter-0.07.tar.gz) = 48097e99e2e830f50923753514c263a3
+SHA256 (Auth-Yubikey_Decrypter-0.07.tar.gz) = e96a1d4f278dd850e0c5b8e0eda6786c7021e7e0a35a12ba94c38ceb56324f52
+SIZE (Auth-Yubikey_Decrypter-0.07.tar.gz) = 3836
diff --git a/security/p5-Auth-YubikeyDecrypter/pkg-descr b/security/p5-Auth-YubikeyDecrypter/pkg-descr
new file mode 100644
index 000000000000..da7c7a30fd7d
--- /dev/null
+++ b/security/p5-Auth-YubikeyDecrypter/pkg-descr
@@ -0,0 +1,15 @@
+Decrypt the output from the yubikey token
+
+The hardware can be found at
+
+http://www.yubico.com/home/index/
+
+The decryption module does only one thing - decrypt the AES encrypted
+OTP from the Yubikey. To this, it requires the OTP, and the AES
+key.
+
+Please note - this module does not perform authentication - it is
+a required component to decrypt the token first before authentication
+can be performed.
+
+WWW: http://search.cpan.org/~massyn/Auth-Yubikey_Decrypter-0.07/
diff --git a/security/p5-Auth-YubikeyDecrypter/pkg-plist b/security/p5-Auth-YubikeyDecrypter/pkg-plist
new file mode 100644
index 000000000000..bf53dde2144f
--- /dev/null
+++ b/security/p5-Auth-YubikeyDecrypter/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Auth/Yubikey_Decrypter.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Auth/Yubikey_Decrypter/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Auth/Yubikey_Decrypter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Auth
+@dirrmtry %%SITE_PERL%%/Auth