aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-NTLM/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-Authen-NTLM/Makefile')
-rw-r--r--security/p5-Authen-NTLM/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/security/p5-Authen-NTLM/Makefile b/security/p5-Authen-NTLM/Makefile
new file mode 100644
index 000000000000..d005568486bc
--- /dev/null
+++ b/security/p5-Authen-NTLM/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Authen-NTLM
+# Date created: June 07 2006
+# Whom: James Thomason <james@divide.org>
+#
+#
+# $FreeBSD$
+
+PORTNAME= NTLM
+PORTVERSION= 1.02
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= james@divide.org
+COMMENT= Perl extension to authenticate against an NTLM server
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Authen::NTLM.3
+
+.include <bsd.port.mk>