aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-PluggableCaptcha/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-Authen-PluggableCaptcha/Makefile')
-rw-r--r--security/p5-Authen-PluggableCaptcha/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/security/p5-Authen-PluggableCaptcha/Makefile b/security/p5-Authen-PluggableCaptcha/Makefile
new file mode 100644
index 000000000000..e09a51918905
--- /dev/null
+++ b/security/p5-Authen-PluggableCaptcha/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Authen-PluggableCaptcha
+# Date created: 2007/02/14
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-PluggableCaptcha
+PORTVERSION= 0.04
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= A pluggable Captcha framework for Perl
+
+BUILD_DEPENDS= p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes \
+ p5-Number-Spell>=0:${PORTSDIR}/textproc/p5-Number-Spell \
+ p5-HTML-Email-Obfuscate>=0:${PORTSDIR}/security/p5-HTML-Email-Obfuscate
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Authen::PluggableCaptcha.3 \
+ Authen::PluggableCaptcha::Challenge.3 \
+ Authen::PluggableCaptcha::ErrorLoggingObject.3 \
+ Authen::PluggableCaptcha::Helpers.3 \
+ Authen::PluggableCaptcha::KeyManager.3 \
+ Authen::PluggableCaptcha::Render.3 \
+ Authen::PluggableCaptcha::StandardAttributesObject.3 \
+ Authen::PluggableCaptcha::Tutorial.3 \
+ Authen::PluggableCaptcha::ValidityObject.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>