aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-IDEA/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-Crypt-IDEA/Makefile')
-rw-r--r--security/p5-Crypt-IDEA/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/security/p5-Crypt-IDEA/Makefile b/security/p5-Crypt-IDEA/Makefile
index 3cb68a1304fe..4d6d6b289fe7 100644
--- a/security/p5-Crypt-IDEA/Makefile
+++ b/security/p5-Crypt-IDEA/Makefile
@@ -5,23 +5,24 @@
# $FreeBSD$
#
-PORTNAME= p5-Crypt-IDEA
+PORTNAME= Crypt-IDEA
PORTVERSION= 1.01
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Crypt
-DISTNAME= Crypt-IDEA-1.01
+PKGNAMEPREFIX= p5-
MAINTAINER= jfitz@FreeBSD.org
RESTRICTED= "Crypto; export-controlled"
-USE_PERL5= YES
+USE_PERL5= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Crypt::IDEA.3
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>