aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-Simple/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-Crypt-Simple/Makefile')
-rw-r--r--security/p5-Crypt-Simple/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/security/p5-Crypt-Simple/Makefile b/security/p5-Crypt-Simple/Makefile
new file mode 100644
index 000000000000..fc190225b379
--- /dev/null
+++ b/security/p5-Crypt-Simple/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Crypt-Simple
+# Date created: 01 Jun 2010
+# Whom: Alexander Kriventsov <avk@vl.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-Simple
+PORTVERSION= 0.06
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= avk@vl.ru
+COMMENT= Perl encrypt stuff simply
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish \
+ ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/FreezeThaw.pm:${PORTSDIR}/devel/p5-FreezeThaw
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::Simple.3
+
+.include <bsd.port.mk>