aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/Makefile')
-rw-r--r--security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/Makefile b/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/Makefile
new file mode 100644
index 000000000000..01c12b3a7161
--- /dev/null
+++ b/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/Makefile
@@ -0,0 +1,24 @@
+# Created by: Henk van Oers <hvo.pm@xs4all.nl>
+# $FreeBSD$
+
+PORTNAME= Dancer-Plugin-Auth-Extensible-Provider-Usergroup
+PORTVERSION= 0.21
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hvo.pm@xs4all.nl
+COMMENT= Extensible authentication framework for Dancer apps
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Dancer>=1.3118:${PORTSDIR}/www/p5-Dancer \
+ p5-Dancer-Plugin-Auth-Extensible>=0:${PORTSDIR}/security/p5-Dancer-Plugin-Auth-Extensible \
+ p5-Dancer-Plugin-Passphrase>=0:${PORTSDIR}/security/p5-Dancer-Plugin-Passphrase
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>