aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Digest-HMAC
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-Digest-HMAC')
-rw-r--r--security/p5-Digest-HMAC/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/security/p5-Digest-HMAC/Makefile b/security/p5-Digest-HMAC/Makefile
index 4d29b50d63bf..931b75a778c0 100644
--- a/security/p5-Digest-HMAC/Makefile
+++ b/security/p5-Digest-HMAC/Makefile
@@ -14,8 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= nork@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -25,4 +24,10 @@ MAN3= Digest::HMAC.3 \
Digest::HMAC_MD5.3 \
Digest::HMAC_SHA1.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+.endif
+
+.include <bsd.port.post.mk>