aboutsummaryrefslogtreecommitdiff
path: root/security/p5-GD-SecurityImage/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-GD-SecurityImage/Makefile')
-rw-r--r--security/p5-GD-SecurityImage/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/security/p5-GD-SecurityImage/Makefile b/security/p5-GD-SecurityImage/Makefile
index f32d5d091191..d179640ce41f 100644
--- a/security/p5-GD-SecurityImage/Makefile
+++ b/security/p5-GD-SecurityImage/Makefile
@@ -7,7 +7,7 @@
PORTNAME= GD-SecurityImage
PORTVERSION= 1.70
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= security perl5
MASTER_SITES= CPAN
@@ -16,8 +16,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 module for creating CAPTCHA security images
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
- ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+
+OPTIONS= IMAGEMAGICK "Build ImageMagick module" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_IMAGEMAGICK)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick
+.endif
+
RUN_DEPENDS= ${BUILD_DEPENDS}
PORTSCOUT= skipv:1.581