aboutsummaryrefslogtreecommitdiff
path: root/security/p5-MD5/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-MD5/Makefile')
-rw-r--r--security/p5-MD5/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/security/p5-MD5/Makefile b/security/p5-MD5/Makefile
index 568c6f434d27..02aadbcf80b1 100644
--- a/security/p5-MD5/Makefile
+++ b/security/p5-MD5/Makefile
@@ -14,12 +14,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-
PERL_CONFIGURE= yes
MAN3= MD5.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>