aboutsummaryrefslogtreecommitdiff
path: root/security/p5-PerlCryptLib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-PerlCryptLib/Makefile')
-rw-r--r--security/p5-PerlCryptLib/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/security/p5-PerlCryptLib/Makefile b/security/p5-PerlCryptLib/Makefile
index a46e2882e898..0d58f97364e0 100644
--- a/security/p5-PerlCryptLib/Makefile
+++ b/security/p5-PerlCryptLib/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= PerlCryptLib
-PORTVERSION= 1.03
+PORTVERSION= 1.04
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/A/AL/ALVAROL
@@ -15,15 +15,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl interface to Peter Guttman cryptlib API
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= cl:${PORTSDIR}/security/cryptlib
RUN_DEPENDS= ${SITE_PERL}/enum.pm:${PORTSDIR}/devel/p5-enum
PERL_CONFIGURE= yes
+USE_OPENSSL= yes
MAN3= PerlCryptLib.3
post-patch:
- ${PERL} -pi -e 's,^use 5\.008.*$$,,' ${WRKSRC}/Makefile.PL
+ ${PERL} -pi -e 's,^#!/bin/bash,#!${LOCALBASE}/bin/bash,;' \
+ -e 's,^read .* cl_path_in .*$$,cl_path_in=${LOCALBASE}/include,' \
+ ${WRKSRC}/configure
+ ${PERL} -pi -e 's,^use 5\.008.*$$,,;' \
+ -e 's,'\''$$, -L${OPENSSLINC} $$&, if /INC/' ${WRKSRC}/Makefile.PL
${PERL} -pi -e 's,\.\./cryptlib322,${LOCALBASE}/include,' \
${WRKSRC}/PerlCryptLib.xs