aboutsummaryrefslogtreecommitdiff
path: root/security/p5-openxpki-client-soap-lite
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-openxpki-client-soap-lite')
-rw-r--r--security/p5-openxpki-client-soap-lite/Makefile30
-rw-r--r--security/p5-openxpki-client-soap-lite/distinfo3
-rw-r--r--security/p5-openxpki-client-soap-lite/pkg-descr24
-rw-r--r--security/p5-openxpki-client-soap-lite/pkg-plist9
4 files changed, 66 insertions, 0 deletions
diff --git a/security/p5-openxpki-client-soap-lite/Makefile b/security/p5-openxpki-client-soap-lite/Makefile
new file mode 100644
index 000000000000..b166547309c4
--- /dev/null
+++ b/security/p5-openxpki-client-soap-lite/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-openxpki-client-soap-lite
+# Date created: 03 Oct 2006
+# Whom: svysh
+#
+# $FreeBSD$
+#
+
+PORTNAME= openxpki-client-soap-lite
+PORTVERSION= 0.9.421
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= openxpki
+PKGNAMEPREFIX= p5-
+DISTNAME= OpenXPKI-Client-SOAP-Lite-${PORTVERSION}
+DIST_SUBDIR= openxpki
+
+MAINTAINER= svysh@cryptocom.ru
+COMMENT= SOAP-Lite toolkit for openxpki
+
+BUILD_DEPENDS= \
+ ${SITE_PERL}/OpenXPKI/Client.pm:${PORTSDIR}/security/p5-openxpki-client \
+ ${SITE_PERL}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= OpenXPKI::Client::SOAP::Lite.3
+USE_PERL5= yes
+USE_GMAKE= yes
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/security/p5-openxpki-client-soap-lite/distinfo b/security/p5-openxpki-client-soap-lite/distinfo
new file mode 100644
index 000000000000..abf34b5d7f63
--- /dev/null
+++ b/security/p5-openxpki-client-soap-lite/distinfo
@@ -0,0 +1,3 @@
+MD5 (openxpki/OpenXPKI-Client-SOAP-Lite-0.9.421.tar.gz) = c8dfbede0b8170d21d770ad14651ae36
+SHA256 (openxpki/OpenXPKI-Client-SOAP-Lite-0.9.421.tar.gz) = aa19111c4765c2e730feb1e440e291dbff024108944a106ffd532a92caefa0fe
+SIZE (openxpki/OpenXPKI-Client-SOAP-Lite-0.9.421.tar.gz) = 4438
diff --git a/security/p5-openxpki-client-soap-lite/pkg-descr b/security/p5-openxpki-client-soap-lite/pkg-descr
new file mode 100644
index 000000000000..dccf2ae39cd6
--- /dev/null
+++ b/security/p5-openxpki-client-soap-lite/pkg-descr
@@ -0,0 +1,24 @@
+A collection of ports for the OpenXPKI suite - Perl based trustcenter
+software for PKI: server and client parts along with deployment tools.
+
+p5-openxpki: core for server part
+p5-openxpki-client: base class for actual clients
+p5-openxpki-i18n: internationalization of the user interface
+p5-openxpki-client-cli: command line interface to local OpenXPKI daemon
+p5-openxpki-client-html-mason: web interface to local OpenXPKI daemon
+p5-openxpki-client-scep: set of SCEP tools
+p5-openxpki-client-soap-lite: set of SOAP-Lite tools
+p5-openxpki-deployment: set or deployment tools
+
+Dependencies of OpenXPKI ports ("A --> B" means that port B depends on port A):
+
+ p5-openxpki-client <-- p5-openxpki (server) --> p5-openxpki-i18n
+ \
+ \ | p5-openxpki-client-cli, p5-openxpki-client-html-mason,
+ \--> | p5-openxpki-client-scep, p5-openxpki-client-soap-lite,
+ | p5-openxpki-deployment.
+Notes:
+I18n is needed for the English interface too. For effective use of deployment,
+it is recommended to install at least one of the clients: ...-cli or ...-mason.
+
+WWW: http://www.openxpki.org/
diff --git a/security/p5-openxpki-client-soap-lite/pkg-plist b/security/p5-openxpki-client-soap-lite/pkg-plist
new file mode 100644
index 000000000000..82a59ce613d3
--- /dev/null
+++ b/security/p5-openxpki-client-soap-lite/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/OpenXPKI/Client/SOAP/Lite.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI/Client/SOAP/Lite/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI/Client/SOAP/Lite
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI/Client/SOAP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI/Client
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenXPKI
+@dirrmtry %%SITE_PERL%%/OpenXPKI/Client/SOAP
+@dirrmtry %%SITE_PERL%%/OpenXPKI/Client
+@dirrmtry %%SITE_PERL%%/OpenXPKI