aboutsummaryrefslogtreecommitdiff
path: root/security/p5-openxpki-client/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-openxpki-client/Makefile')
-rw-r--r--security/p5-openxpki-client/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/security/p5-openxpki-client/Makefile b/security/p5-openxpki-client/Makefile
new file mode 100644
index 000000000000..962bc804d76a
--- /dev/null
+++ b/security/p5-openxpki-client/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-openxpki-client
+# Date created: 03 Oct 2006
+# Whom: svysh
+#
+# $FreeBSD$
+#
+
+PORTNAME= openxpki-client
+PORTVERSION= 0.9.450
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= openxpki
+PKGNAMEPREFIX= p5-
+DISTNAME= OpenXPKI-Client-${PORTVERSION}
+DIST_SUBDIR= openxpki
+
+MAINTAINER= svysh@cryptocom.ru
+COMMENT= Perl based trustcenter software for PKI: base class for actual clients
+
+BUILD_DEPENDS= \
+ ${SITE_PERL}/${PERL_ARCH}/OpenXPKI.pm:${PORTSDIR}/security/p5-openxpki
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= OpenXPKI::Client.3 \
+ OpenXPKI::Client::API.3
+USE_PERL5= yes
+USE_GMAKE= yes
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>