aboutsummaryrefslogtreecommitdiff
path: root/security/p5-openxpki/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-openxpki/Makefile')
-rw-r--r--security/p5-openxpki/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/security/p5-openxpki/Makefile b/security/p5-openxpki/Makefile
index 622d38d4d397..4fc5cc0ca9cd 100644
--- a/security/p5-openxpki/Makefile
+++ b/security/p5-openxpki/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openxpki
-PORTVERSION= 1.5.0
+PORTVERSION= 1.8.0
DISTVERSIONPREFIX= v
CATEGORIES= security perl5
PKGNAMEPREFIX= p5-
@@ -121,14 +121,15 @@ IGNORE= this version of OpenXPKI is not fully functional with LibreSSL library,
OXLIB= ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/OpenXPKI/OpenXPKI.so
post-install:
- ${CHMOD} u+w ${OXLIB}
${STRIP_CMD} ${OXLIB}
- ${CHMOD} u-w ${OXLIB}
+
post-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @(cd ${WRKSRC}/../.. && ${COPYTREE_SHARE} config ${STAGEDIR}${EXAMPLESDIR})
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} "htdocs cgi-bin" ${STAGEDIR}${EXAMPLESDIR})
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/../.. && ${COPYTREE_SHARE} config ${STAGEDIR}${EXAMPLESDIR})
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "htdocs cgi-bin" ${STAGEDIR}${EXAMPLESDIR})
+
post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- @(cd ${WRKSRC}/../../doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/../../doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+
.include <bsd.port.post.mk>