aboutsummaryrefslogtreecommitdiff
path: root/security/pam-mysql/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/pam-mysql/Makefile')
-rw-r--r--security/pam-mysql/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/security/pam-mysql/Makefile b/security/pam-mysql/Makefile
index 32d50965336f..3e9171a1606b 100644
--- a/security/pam-mysql/Makefile
+++ b/security/pam-mysql/Makefile
@@ -11,10 +11,15 @@ DISTNAME= ${PORTNAME}-0.7RC1${DISTVERSIONSUFFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Pam module for authenticating with MySQL
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= libtool:keepla
USE_MYSQL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-mysql=${LOCALBASE} --with-pam-mods-dir=${PREFIX}/lib --with-pam=/usr
+CONFIGURE_ARGS= --with-mysql=${LOCALBASE} \
+ --with-pam-mods-dir=${PREFIX}/lib \
+ --with-pam=/usr
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -27,10 +32,11 @@ SSL_DESC= Build with OpenSSL support (non-crypt()ish MD5 hash)
SSL_CONFIGURE_WITH= openssl
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pam_mysql.so
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pam_mysql.so
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog \
- ${WRKSRC}/NEWS \
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${WRKSRC}/NEWS \
${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>