aboutsummaryrefslogtreecommitdiff
path: root/security/pidentd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/pidentd/Makefile')
-rw-r--r--security/pidentd/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/security/pidentd/Makefile b/security/pidentd/Makefile
index a95e0e975f4d..59cd50bcd6c8 100644
--- a/security/pidentd/Makefile
+++ b/security/pidentd/Makefile
@@ -7,25 +7,37 @@
#
DISTNAME= pidentd-2.8.5
-CATEGORIES= security net
+CATEGORIES= security net ipv6
MASTER_SITES= ftp://ftp.lysator.liu.se/pub/ident/servers/ \
ftp://ftp.fu-berlin.de/unix/security/ident/servers/
+PATCH_SITES= http://www.imasy.or.jp/~ume/ipv6/
+PATCHFILES= pidentd-2.8.5-ipv6-1.5.diff.gz
+PATCH_DIST_STRIP= -p2
+
MAINTAINER= torstenb@FreeBSD.org
ALL_TARGET= freebsd
MAKE_ENV= REALPREFIX=${PREFIX}
MAN8= identd.8 idecrypt.8
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 400014
+ADD_GDEFS+= -DINET6 -D__ss_family=ss_family -D__ss_len=ss_len
+.endif
+
# Uncomment to activate the use of verifiable "cookies". The idea is to be
# able to detect fake "logs" intended to get your innocent users in trouble.
# Naturally, since it uses libdes, you must have the "secure" dist installed.
# USE_DES= true
.if defined(USE_DES)
-ADD_GDEFS= -DINCLUDE_CRYPT
+ADD_GDEFS+= -DINCLUDE_CRYPT
ADD_GLIBS= -ldes
+.endif
+.if defined(USE_DES) || ${OSVERSION} >= 400014
MAKE_ENV+= ADD_GDEFS="${ADD_GDEFS}" ADD_GLIBS="${ADD_GLIBS}"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>