aboutsummaryrefslogtreecommitdiff
path: root/security/pidentd
diff options
context:
space:
mode:
Diffstat (limited to 'security/pidentd')
-rw-r--r--security/pidentd/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/security/pidentd/Makefile b/security/pidentd/Makefile
index 5bfd077b6140..b259c07ccdba 100644
--- a/security/pidentd/Makefile
+++ b/security/pidentd/Makefile
@@ -30,14 +30,14 @@ ADD_GDEFS+= -DINET6 -D__ss_family=ss_family -D__ss_len=ss_len
# Uncomment to activate the use of verifiable "cookies". The idea is to be
# able to detect fake "logs" intended to get your innocent users in trouble.
-# Naturally, since it uses libcrypto, you must have the "secure" dist
-# installed.
+# Naturally, since it uses libcrypto, you must have OpenSSL installed.
#WITH_DES= yes
.if defined(WITH_DES)
+.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
ADD_GDEFS+= -DINCLUDE_CRYPT -DOPENSSL_DES_LIBDES_COMPATIBILITY \
- -I/usr/include/openssl
-ADD_GLIBS= -lcrypto
+ -I${OPENSSLINC} -I${OPENSSLINC}/openssl
+ADD_GLIBS= -L${OPENSSLLIB} -lcrypto
.endif
.if defined(WITH_DES) || ${OSVERSION} >= 400014
MAKE_ENV+= ADD_GDEFS="${ADD_GDEFS}" ADD_GLIBS="${ADD_GLIBS}"