aboutsummaryrefslogtreecommitdiff
path: root/security/pidgin-encryption/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/pidgin-encryption/Makefile')
-rw-r--r--security/pidgin-encryption/Makefile50
1 files changed, 0 insertions, 50 deletions
diff --git a/security/pidgin-encryption/Makefile b/security/pidgin-encryption/Makefile
deleted file mode 100644
index c2b9f83e9aaa..000000000000
--- a/security/pidgin-encryption/Makefile
+++ /dev/null
@@ -1,50 +0,0 @@
-# New ports collection makefile for: gaim-encryption
-# Date created: 2004-05-01
-# Whom: ports@c0decafe.net
-#
-# $FreeBSD$
-#
-
-PORTNAME= encryption
-PORTVERSION= 2.35
-PORTREVISION= 2
-CATEGORIES= security net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
-PKGNAMEPREFIX= gaim-
-DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
-
-MAINTAINER= ports@c0decafe.net
-COMMENT= Provides transparent RSA encryption as a Gaim plugin
-
-BUILD_DEPENDS= ${X11BASE}/include/gaim/config.h:${PORTSDIR}/net/gaim
-RUN_DEPENDS= gaim:${PORTSDIR}/net/gaim
-LIB_DEPENDS= nss3:${PORTSDIR}/security/nss
-
-USE_X_PREFIX= yes
-USE_GMAKE= yes
-USE_GNOME= gtk20
-USE_LIBTOOL_VER=15
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CONFIGURE_ARGS= --with-nspr-includes=${LOCALBASE}/include/nspr \
- --with-nspr-libs=${LOCALBASE}/lib \
- --with-nss-includes=${LOCALBASE}/include/nss/nss \
- --with-nss-libs=${LOCALBASE}/lib
-
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-CONFIGURE_ARGS+=--with-libintl-prefix=${LOCALBASE}
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "WARNING: make sure net/gaim is built with NSS support (it is, by default)"
- @${ECHO_MSG} ""
- @${ECHO_MSG} ""
-
-.include <bsd.port.mk>