aboutsummaryrefslogtreecommitdiff
path: root/security/pks/files
diff options
context:
space:
mode:
Diffstat (limited to 'security/pks/files')
-rw-r--r--security/pks/files/patch-configure.in4
-rw-r--r--security/pks/files/patch-kd_generic.c26
-rw-r--r--security/pks/files/patch-kd_search.c13
-rw-r--r--security/pks/files/patch-mkpksdconf.in4
4 files changed, 43 insertions, 4 deletions
diff --git a/security/pks/files/patch-configure.in b/security/pks/files/patch-configure.in
index 466af4727cc4..39a93721326d 100644
--- a/security/pks/files/patch-configure.in
+++ b/security/pks/files/patch-configure.in
@@ -1,5 +1,5 @@
---- ./configure.in.orig 2011-03-21 20:49:39.000000000 +0100
-+++ ./configure.in 2011-03-21 20:50:42.000000000 +0100
+--- ./configure.in.orig 2004-01-18 00:19:56.000000000 +0100
++++ ./configure.in 2014-08-15 18:32:37.000000000 +0200
@@ -74,126 +74,6 @@
# Checks for libraries.
dnl Checks for Berkeley DB
diff --git a/security/pks/files/patch-kd_generic.c b/security/pks/files/patch-kd_generic.c
new file mode 100644
index 000000000000..fe385b4af2c9
--- /dev/null
+++ b/security/pks/files/patch-kd_generic.c
@@ -0,0 +1,26 @@
+--- ./kd_generic.c.orig 2003-08-04 21:57:27.000000000 +0200
++++ ./kd_generic.c 2014-08-15 18:41:14.000000000 +0200
+@@ -325,13 +325,13 @@
+ /* create/open/close/sync */
+
+ static int
+-kd_worddata_compare (DB * db, const DBT * a, const DBT * b)
++kd_worddata_compare (DB * db, const DBT * a, const DBT * b, size_t *locp)
+ {
+ return (memcmp (b->data, a->data, 12));
+ }
+
+ static void
+-kd_errcall (const char *db_errpfx, char *buffer)
++kd_errcall (const DB_ENV *dbenv, const char *db_errpfx, const char *buffer)
+ {
+ log_error (db_errpfx ? db_errpfx : "db_errcall", buffer);
+ }
+@@ -396,7 +396,6 @@
+ if (oflags & KD_OPEN_RECOVER)
+ {
+ appflags |= DB_INIT_LOG | DB_RECOVER | DB_CREATE;
+- dbenv->set_verbose (dbenv, DB_VERB_CHKPOINT, 1);
+ dbenv->set_verbose (dbenv, DB_VERB_WAITSFOR, 1);
+ dbenv->set_verbose (dbenv, DB_VERB_DEADLOCK, 1);
+ dbenv->set_verbose (dbenv, DB_VERB_RECOVERY, 1);
diff --git a/security/pks/files/patch-kd_search.c b/security/pks/files/patch-kd_search.c
new file mode 100644
index 000000000000..e5e70ad79352
--- /dev/null
+++ b/security/pks/files/patch-kd_search.c
@@ -0,0 +1,13 @@
+--- ./kd_search.c.orig 2003-08-04 21:57:34.000000000 +0200
++++ ./kd_search.c 2014-08-15 18:37:29.000000000 +0200
+@@ -1058,8 +1058,8 @@
+ if (we->len > sizeof (word))
+ {
+ s->err->fatal = 0;
+- sprintf (s->err->buf, "search word is greater than %d characters",
+- sizeof (word));
++ sprintf (s->err->buf, "search word is greater than %lu characters",
++ (unsigned long)sizeof (word));
+ return (0);
+ }
+
diff --git a/security/pks/files/patch-mkpksdconf.in b/security/pks/files/patch-mkpksdconf.in
index b48a3d74e9e5..bab902712ba5 100644
--- a/security/pks/files/patch-mkpksdconf.in
+++ b/security/pks/files/patch-mkpksdconf.in
@@ -1,5 +1,5 @@
---- ./mkpksdconf.in.orig 2014-01-22 15:36:39.574285045 -0500
-+++ ./mkpksdconf.in 2014-01-22 15:37:49.289280305 -0500
+--- ./mkpksdconf.in.orig 2003-02-28 18:27:20.000000000 +0100
++++ ./mkpksdconf.in 2014-08-15 18:32:37.000000000 +0200
@@ -44,7 +44,7 @@
cat << EOF