aboutsummaryrefslogtreecommitdiff
path: root/security/py-certbot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-certbot/Makefile')
-rw-r--r--security/py-certbot/Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/security/py-certbot/Makefile b/security/py-certbot/Makefile
index 66194bd7210f..4e129330b469 100644
--- a/security/py-certbot/Makefile
+++ b/security/py-certbot/Makefile
@@ -14,19 +14,19 @@ COMMENT= Let's Encrypt client
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${PORTVERSION}:security/py-acme \
- ${PYTHON_PKGNAMEPREFIX}configargparse>=0.9.3:devel/py-configargparse \
- ${PYTHON_PKGNAMEPREFIX}configobj>0:devel/py-configobj \
- ${PYTHON_PKGNAMEPREFIX}cryptography>=1.2:security/py-cryptography \
- ${PYTHON_PKGNAMEPREFIX}parsedatetime>=1.3:devel/py-parsedatetime \
- ${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl \
- ${PYTHON_PKGNAMEPREFIX}pyrfc3339>0:devel/py-pyrfc3339 \
- ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz \
- ${PYTHON_PKGNAMEPREFIX}setuptools>=1.0:devel/${PYTHON_PKGNAMEPREFIX}setuptools \
- ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six \
- ${PYTHON_PKGNAMEPREFIX}zope.component>0:devel/py-zope.component \
- ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${PORTVERSION}:security/py-acme@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}configargparse>=0.9.3:devel/py-configargparse@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}configobj>0:devel/py-configobj@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>=1.2:security/py-cryptography@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}parsedatetime>=1.3:devel/py-parsedatetime@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyrfc3339>0:devel/py-pyrfc3339@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=1.0:devel/py-setuptools@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.component>0:devel/py-zope.component@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${FLAVOR}
# Actually 2.7,3.3+
USES= python