aboutsummaryrefslogtreecommitdiff
path: root/security/py-cybox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-cybox/Makefile')
-rw-r--r--security/py-cybox/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/security/py-cybox/Makefile b/security/py-cybox/Makefile
new file mode 100644
index 000000000000..d7a28726c787
--- /dev/null
+++ b/security/py-cybox/Makefile
@@ -0,0 +1,30 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cybox
+PORTVERSION= 2.1.0.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Python library for parsing, manipulating, and generating CybOX content
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:${PORTSDIR}/devel/py-dateutil \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=3.1:${PORTSDIR}/devel/py-lxml
+
+USE_PYTHON= 2
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST=yes
+
+PORTDOCS= README.rst
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>