aboutsummaryrefslogtreecommitdiff
path: root/security/py-htpasswd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-htpasswd/Makefile')
-rw-r--r--security/py-htpasswd/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/security/py-htpasswd/Makefile b/security/py-htpasswd/Makefile
new file mode 100644
index 000000000000..b40f89bafc38
--- /dev/null
+++ b/security/py-htpasswd/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-htpasswd
+# Date created: 2011-08-26
+# Whom: Aldis Berjoza <aldis@bsdroot.lv>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htpasswd
+PORTVERSION= 2008.03.05
+CATEGORIES= security python
+MASTER_SITES= http://files.bsdroot.lv/my/FreeBSD/distfiles/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= aldis@bsdroot.lv
+COMMENT= Replacement for htpasswd
+
+USE_PYTHON= YES
+USE_XZ= YES
+
+PLIST_FILES= bin/${PORTNAME}.py
+
+NO_BUILD= YES
+NO_WRKSUBDIR= YES
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.py ${PREFIX}/bin/
+
+.include <bsd.port.mk>