aboutsummaryrefslogtreecommitdiff
path: root/security/py-keyring/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-keyring/Makefile')
-rw-r--r--security/py-keyring/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/security/py-keyring/Makefile b/security/py-keyring/Makefile
index c113313d9655..c9e5ab931d74 100644
--- a/security/py-keyring/Makefile
+++ b/security/py-keyring/Makefile
@@ -12,7 +12,7 @@ COMMENT= Store and access your passwords safely
LICENSE= PSFL
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.15.1:devel/py-setuptools_scm
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.15.1:devel/py-setuptools_scm@${FLAVOR}
NO_ARCH= yes
USES= python
@@ -24,8 +24,8 @@ DBUS_DESC= Install Python DBUS to support the kwallet backend
KEYRINGS_ALT_DESC= Install Alternate Python keyring implementations backend
SECRET_SERVICE_DESC= Install SecretStorage to support the SecretService backend
-DBUS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus
-KEYRINGS_ALT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}keyrings.alt>0:security/py-keyrings.alt
-SECRET_SERVICE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}SecretStorage>=1.0.0:security/py-SecretStorage
+DBUS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${FLAVOR}
+KEYRINGS_ALT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}keyrings.alt>0:security/py-keyrings.alt@${FLAVOR}
+SECRET_SERVICE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}SecretStorage>=1.0.0:security/py-SecretStorage@${FLAVOR}
.include <bsd.port.mk>