aboutsummaryrefslogtreecommitdiff
path: root/security/py-posix1e/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-posix1e/Makefile')
-rw-r--r--security/py-posix1e/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/security/py-posix1e/Makefile b/security/py-posix1e/Makefile
new file mode 100644
index 000000000000..9171e44630f3
--- /dev/null
+++ b/security/py-posix1e/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: py-posix1e
+# Date created: 2 January 2003
+# Whom: Hye-Shik Chang
+#
+# $FreeBSD$
+#
+
+PORTNAME= posix1e
+PORTVERSION= 0.2.1
+CATEGORIES= security python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pylibacl
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pylibacl-${PORTVERSION}
+
+MAINTAINER= perky@FreeBSD.org
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_REINPLACE= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e \
+ 's,/usr/share/doc/pylibacl,${PREFIX}/share/doc/py-posix1e,g' \
+ ${WRKSRC}/setup.py
+.if ${OSVERSION} >= 500038
+ ${REINPLACE_CMD} -e 's,^.*libs.append.*posix1e.*$$,,g' \
+ ${WRKSRC}/setup.py
+.endif
+
+.include <bsd.port.post.mk>