aboutsummaryrefslogtreecommitdiff
path: root/security/py-pymacaroons-pynacl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-pymacaroons-pynacl/Makefile')
-rw-r--r--security/py-pymacaroons-pynacl/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/security/py-pymacaroons-pynacl/Makefile b/security/py-pymacaroons-pynacl/Makefile
new file mode 100644
index 000000000000..1b82562c5778
--- /dev/null
+++ b/security/py-pymacaroons-pynacl/Makefile
@@ -0,0 +1,32 @@
+# Created by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
+# $FreeBSD$
+
+PORTNAME= pymacaroons-pynacl
+PORTVERSION= 0.9.3
+DISTVERSIONPREFIX= v
+CATEGORIES= security devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= brendan+freebsd@bbqsrc.net
+COMMENT= Macaroon library for Python
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pynacl>=0.3.0:${PORTSDIR}/security/py-pynacl \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.8.0:${PORTSDIR}/devel/py-six
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hypothesis>0:${PORTSDIR}/devel/py-hypothesis \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock \
+ ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+
+GH_ACCOUNT= matrix-org
+GH_PROJECT= pymacaroons
+
+do-test:
+ @(cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} nosetests)
+
+.include <bsd.port.mk>