aboutsummaryrefslogtreecommitdiff
path: root/security/py-rijndael/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-rijndael/Makefile')
-rw-r--r--security/py-rijndael/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/security/py-rijndael/Makefile b/security/py-rijndael/Makefile
new file mode 100644
index 000000000000..9861bc2a73b0
--- /dev/null
+++ b/security/py-rijndael/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# New ports collection makefile for: py-rijndael
+# Date created: Jul 23, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= rijndael
+PORTVERSION= 1.1
+CATEGORIES= security python
+MASTER_SITES= http://bluesine.com/archives/software/python-mods/rijndael/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyRijndael-${PORTVERSION}.py
+EXTRACT_SUFX= .gz
+
+MAINTAINER= ports@FreeBSD.org
+
+EXTRACT_AFTER_ARGS= > ${DISTNAME}
+USE_PYTHON= yes
+NO_WRKSUBDIR= yes
+
+post-extract:
+ @${MV} ${WRKSRC}/${DISTNAME} ${WRKSRC}/pyRijndael.py
+
+do-build:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -c 'import pyRijndael'
+ @cd ${WRKSRC} && ${PYTHON_CMD} -O -c 'import pyRijndael'
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/pyRijndael.* ${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>