aboutsummaryrefslogtreecommitdiff
path: root/security/py-twistedConch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-twistedConch/Makefile')
-rw-r--r--security/py-twistedConch/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/security/py-twistedConch/Makefile b/security/py-twistedConch/Makefile
index 11a880c1acd8..06875249eb16 100644
--- a/security/py-twistedConch/Makefile
+++ b/security/py-twistedConch/Makefile
@@ -1,30 +1,26 @@
-# New ports collection makefile for: py-twistedConch
-# Date created: 13 April 2005
-# Whom: Neal Nelson <neal@nelson.name>
-#
+# Created by: Neal Nelson <neal@nelson.name>
# $FreeBSD$
-#
PORTNAME= twistedConch
-PORTVERSION= 12.1.0
+PORTVERSION= 13.1.0
CATEGORIES= security devel python
-MASTER_SITES= http://twistedmatrix.com/Releases/Conch/${PORTVERSION:R}/
+MASTER_SITES= http://twistedmatrix.com/Releases/Conch/${PORTVERSION:R}/ \
+ LOCAL/sunpoet
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= TwistedConch-${PORTVERSION}
MAINTAINER= python@FreeBSD.org
-COMMENT= An SSH and SFTP protocol implementation with clients and servers
+COMMENT= SSH and SFTP protocol implementation with clients and servers
LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twistedCore>=${PORTVERSION}:${PORTSDIR}/devel/py-twistedCore
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0.0.9a:${PORTSDIR}/devel/py-asn1 \
${PYTHON_PKGNAMEPREFIX}twistedCore>=${PORTVERSION}:${PORTSDIR}/devel/py-twistedCore
USE_BZIP2= yes
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= ${PORTNAME:S/twisted/Twisted_/}
.include <bsd.port.mk>