aboutsummaryrefslogtreecommitdiff
path: root/security/py-twistedConch
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-twistedConch')
-rw-r--r--security/py-twistedConch/Makefile18
-rw-r--r--security/py-twistedConch/distinfo4
-rw-r--r--security/py-twistedConch/pkg-plist12
3 files changed, 21 insertions, 13 deletions
diff --git a/security/py-twistedConch/Makefile b/security/py-twistedConch/Makefile
index 11a880c1acd8..06875249eb16 100644
--- a/security/py-twistedConch/Makefile
+++ b/security/py-twistedConch/Makefile
@@ -1,30 +1,26 @@
-# New ports collection makefile for: py-twistedConch
-# Date created: 13 April 2005
-# Whom: Neal Nelson <neal@nelson.name>
-#
+# Created by: Neal Nelson <neal@nelson.name>
# $FreeBSD$
-#
PORTNAME= twistedConch
-PORTVERSION= 12.1.0
+PORTVERSION= 13.1.0
CATEGORIES= security devel python
-MASTER_SITES= http://twistedmatrix.com/Releases/Conch/${PORTVERSION:R}/
+MASTER_SITES= http://twistedmatrix.com/Releases/Conch/${PORTVERSION:R}/ \
+ LOCAL/sunpoet
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= TwistedConch-${PORTVERSION}
MAINTAINER= python@FreeBSD.org
-COMMENT= An SSH and SFTP protocol implementation with clients and servers
+COMMENT= SSH and SFTP protocol implementation with clients and servers
LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twistedCore>=${PORTVERSION}:${PORTSDIR}/devel/py-twistedCore
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0.0.9a:${PORTSDIR}/devel/py-asn1 \
${PYTHON_PKGNAMEPREFIX}twistedCore>=${PORTVERSION}:${PORTSDIR}/devel/py-twistedCore
USE_BZIP2= yes
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= ${PORTNAME:S/twisted/Twisted_/}
.include <bsd.port.mk>
diff --git a/security/py-twistedConch/distinfo b/security/py-twistedConch/distinfo
index 810c674189a2..160aeed904bb 100644
--- a/security/py-twistedConch/distinfo
+++ b/security/py-twistedConch/distinfo
@@ -1,2 +1,2 @@
-SHA256 (TwistedConch-12.1.0.tar.bz2) = e3be79c0de23d80fe09d46221581de554fbb3918f95f368c47396237acb06821
-SIZE (TwistedConch-12.1.0.tar.bz2) = 215724
+SHA256 (TwistedConch-13.1.0.tar.bz2) = 570f961d23ef30bf4e3f8629dcc22731fdfe495ce78e8ae6cef7dc9c48d7d89f
+SIZE (TwistedConch-13.1.0.tar.bz2) = 241112
diff --git a/security/py-twistedConch/pkg-plist b/security/py-twistedConch/pkg-plist
index 7baa26a13c14..b7a2a7b4ed33 100644
--- a/security/py-twistedConch/pkg-plist
+++ b/security/py-twistedConch/pkg-plist
@@ -35,6 +35,9 @@ bin/tkconch
%%PYTHON_SITELIBDIR%%/twisted/conch/client/options.py
%%PYTHON_SITELIBDIR%%/twisted/conch/client/options.pyc
%%PYTHON_SITELIBDIR%%/twisted/conch/client/options.pyo
+%%PYTHON_SITELIBDIR%%/twisted/conch/endpoints.py
+%%PYTHON_SITELIBDIR%%/twisted/conch/endpoints.pyc
+%%PYTHON_SITELIBDIR%%/twisted/conch/endpoints.pyo
%%PYTHON_SITELIBDIR%%/twisted/conch/error.py
%%PYTHON_SITELIBDIR%%/twisted/conch/error.pyc
%%PYTHON_SITELIBDIR%%/twisted/conch/error.pyo
@@ -107,6 +110,9 @@ bin/tkconch
%%PYTHON_SITELIBDIR%%/twisted/conch/ssh/__init__.py
%%PYTHON_SITELIBDIR%%/twisted/conch/ssh/__init__.pyc
%%PYTHON_SITELIBDIR%%/twisted/conch/ssh/__init__.pyo
+%%PYTHON_SITELIBDIR%%/twisted/conch/ssh/address.py
+%%PYTHON_SITELIBDIR%%/twisted/conch/ssh/address.pyc
+%%PYTHON_SITELIBDIR%%/twisted/conch/ssh/address.pyo
%%PYTHON_SITELIBDIR%%/twisted/conch/ssh/agent.py
%%PYTHON_SITELIBDIR%%/twisted/conch/ssh/agent.pyc
%%PYTHON_SITELIBDIR%%/twisted/conch/ssh/agent.pyo
@@ -161,6 +167,9 @@ bin/tkconch
%%PYTHON_SITELIBDIR%%/twisted/conch/test/keydata.py
%%PYTHON_SITELIBDIR%%/twisted/conch/test/keydata.pyc
%%PYTHON_SITELIBDIR%%/twisted/conch/test/keydata.pyo
+%%PYTHON_SITELIBDIR%%/twisted/conch/test/test_address.py
+%%PYTHON_SITELIBDIR%%/twisted/conch/test/test_address.pyc
+%%PYTHON_SITELIBDIR%%/twisted/conch/test/test_address.pyo
%%PYTHON_SITELIBDIR%%/twisted/conch/test/test_agent.py
%%PYTHON_SITELIBDIR%%/twisted/conch/test/test_agent.pyc
%%PYTHON_SITELIBDIR%%/twisted/conch/test/test_agent.pyo
@@ -185,6 +194,9 @@ bin/tkconch
%%PYTHON_SITELIBDIR%%/twisted/conch/test/test_default.py
%%PYTHON_SITELIBDIR%%/twisted/conch/test/test_default.pyc
%%PYTHON_SITELIBDIR%%/twisted/conch/test/test_default.pyo
+%%PYTHON_SITELIBDIR%%/twisted/conch/test/test_endpoints.py
+%%PYTHON_SITELIBDIR%%/twisted/conch/test/test_endpoints.pyc
+%%PYTHON_SITELIBDIR%%/twisted/conch/test/test_endpoints.pyo
%%PYTHON_SITELIBDIR%%/twisted/conch/test/test_filetransfer.py
%%PYTHON_SITELIBDIR%%/twisted/conch/test/test_filetransfer.pyc
%%PYTHON_SITELIBDIR%%/twisted/conch/test/test_filetransfer.pyo