aboutsummaryrefslogtreecommitdiff
path: root/security/py-zope.authentication/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-zope.authentication/Makefile')
-rw-r--r--security/py-zope.authentication/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/security/py-zope.authentication/Makefile b/security/py-zope.authentication/Makefile
new file mode 100644
index 000000000000..d951ef850e4b
--- /dev/null
+++ b/security/py-zope.authentication/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: py-zope.authentication
+# Date created: 18 December 2011
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zope.authentication
+PORTVERSION= 3.7.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Definition of authentication basics for the Zope Framework
+
+LICENSE= ZPL21
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.browser>=0:${PORTSDIR}/devel/py-zope.browser \
+ ${PYTHON_PKGNAMEPREFIX}zope.component>=3.6.0:${PORTSDIR}/devel/py-zope.component \
+ ${PYTHON_PKGNAMEPREFIX}zope.i18nmessageid>=0:${PORTSDIR}/textproc/py-zope.i18nmessageid \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
+ ${PYTHON_PKGNAMEPREFIX}zope.schema>=0:${PORTSDIR}/devel/py-zope.schema \
+ ${PYTHON_PKGNAMEPREFIX}zope.security>=0:${PORTSDIR}/security/py-zope.security
+
+DIST_SUBDIR= zope
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+USE_ZIP= yes
+
+.include <bsd.port.mk>