aboutsummaryrefslogtreecommitdiff
path: root/security/quantis/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/quantis/Makefile')
-rw-r--r--security/quantis/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/security/quantis/Makefile b/security/quantis/Makefile
index cd0bd7647aa7..be28d5744db6 100644
--- a/security/quantis/Makefile
+++ b/security/quantis/Makefile
@@ -3,6 +3,7 @@
PORTNAME= quantis
DISTVERSION= v18.03.08
+PORTREVISION= 1
CATEGORIES= security devel java
MASTER_SITES= https://www.idquantique.com/wordpress/wp-content/uploads/
DISTNAME= Quantis-${DISTVERSION}
@@ -14,14 +15,15 @@ LICENSE= BSD3CLAUSE GPLv2
LICENSE_COMB= dual
LICENSE_FILE_BSD3CLAUSE=${WRKSRC}/../License.txt
+BROKEN= does not build
BROKEN_aarch64= fails to build: Could not find JNI (missing: JAVA_AWT_LIBRARY JAVA_JVM_LIBRARY)
BROKEN_armv6= fails to build: Could not find JNI (missing: JAVA_AWT_LIBRARY JAVA_JVM_LIBRARY)
BROKEN_armv7= fails to build: Could not find JNI (missing: JAVA_AWT_LIBRARY JAVA_JVM_LIBRARY)
-USES= cmake compiler:c++11-lang qt:4 zip:infozip
+USES= cmake compiler:c++11-lang zip:infozip
OPTIONS_DEFINE= PCI USB JAVA COMPAT TOOL GUI DOCS EXAMPLES
-OPTIONS_DEFAULT=PCI USB JAVA TOOL GUI
+OPTIONS_DEFAULT=PCI USB JAVA TOOL
NO_OPTIONS_SORT=yes
PCI_DESC= Enable Quantis PCI support
@@ -76,6 +78,10 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libboost_date_time.a:devel/boost-libs
CXXFLAGS+= -I${LOCALBASE}/include
. if ${PORT_OPTIONS:MGUI}
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+
+USES+= qt:4
USE_QT+= corelib gui moc_build uic_build rcc_build qmake_build
. else
CMAKE_ARGS+= -DDISABLE_EASYQUANTIS_GUI=1