aboutsummaryrefslogtreecommitdiff
path: root/security/racoon2/files
diff options
context:
space:
mode:
Diffstat (limited to 'security/racoon2/files')
-rw-r--r--security/racoon2/files/patch-configure11
-rw-r--r--security/racoon2/files/patch-fastipsec420
-rw-r--r--security/racoon2/files/patch-rcvar33
-rw-r--r--security/racoon2/files/patch-samples-Makefile.in25
-rw-r--r--security/racoon2/files/patch-samples-rc.d-iked.in12
-rw-r--r--security/racoon2/files/patch-samples-rc.d-kinkd.in12
-rw-r--r--security/racoon2/files/patch-samples-rc.d-spmd.in11
7 files changed, 45 insertions, 479 deletions
diff --git a/security/racoon2/files/patch-configure b/security/racoon2/files/patch-configure
deleted file mode 100644
index ab6afbdb92ce..000000000000
--- a/security/racoon2/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure- Tue May 30 12:46:28 2006
-+++ configure Tue May 30 12:47:05 2006
-@@ -1517,7 +1517,7 @@
- netbsd1.[56]*|netbsd[2-9].*)
- startup_scripts=rc-d
- ;;
-- freebsd[5-9].*)
-+ freebsd*)
- startup_scripts=rc-d
- ;;
- *)
diff --git a/security/racoon2/files/patch-fastipsec b/security/racoon2/files/patch-fastipsec
deleted file mode 100644
index f3299ba82b75..000000000000
--- a/security/racoon2/files/patch-fastipsec
+++ /dev/null
@@ -1,420 +0,0 @@
-Index: iked/config.h.in
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/iked/config.h.in,v
-retrieving revision 1.19
-diff -u -r1.19 config.h.in
---- iked/config.h.in 24 Jul 2007 06:22:19 -0000 1.19
-+++ iked/config.h.in 17 Aug 2007 07:18:32 -0000
-@@ -54,6 +54,9 @@
- /* Define if you have the <netinet6/ipsec.h> header file. */
- #undef HAVE_NETINET6_IPSEC_H
-
-+/* Define if you have the <netipsec/ipsec.h> header file. */
-+#undef HAVE_NETIPSEC_IPSEC_H
-+
- /* Define if you have the <openssl/aes.h> header file. */
- #undef HAVE_OPENSSL_AES_H
-
-Index: iked/configure
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/iked/configure,v
-retrieving revision 1.54
-diff -u -r1.54 configure
---- iked/configure 24 Jul 2007 06:22:19 -0000 1.54
-+++ iked/configure 17 Aug 2007 07:18:43 -0000
-@@ -1220,7 +1220,7 @@
-
- fi
-
--for ac_hdr in limits.h netdb.h netinet/in.h netinet6/ipsec.h stdarg.h stddef.h stdlib.h string.h sys/param.h sys/socket.h sys/time.h unistd.h inttypes.h stdint.h
-+for ac_hdr in limits.h netdb.h netinet/in.h netinet6/ipsec.h netipsec/ipsec.h stdarg.h stddef.h stdlib.h string.h sys/param.h sys/socket.h sys/time.h unistd.h inttypes.h stdint.h
- do
- ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
- echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-Index: iked/configure.in
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/iked/configure.in,v
-retrieving revision 1.61
-diff -u -r1.61 configure.in
---- iked/configure.in 24 Jul 2007 06:22:19 -0000 1.61
-+++ iked/configure.in 17 Aug 2007 07:18:43 -0000
-@@ -83,7 +83,7 @@
-
- # Checks for header files.
- AC_HEADER_STDC
--AC_CHECK_HEADERS([limits.h netdb.h netinet/in.h netinet6/ipsec.h stdarg.h stddef.h stdlib.h string.h sys/param.h sys/socket.h sys/time.h unistd.h inttypes.h stdint.h])
-+AC_CHECK_HEADERS([limits.h netdb.h netinet/in.h netinet6/ipsec.h netipsec/ipsec.h stdarg.h stddef.h stdlib.h string.h sys/param.h sys/socket.h sys/time.h unistd.h inttypes.h stdint.h])
-
- dnl the directory built the kernel should be defined, in particular linux.
- AC_MSG_CHECKING(if --with-kernel-build-dir option is specified)
-Index: iked/sockmisc.c
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/iked/sockmisc.c,v
-retrieving revision 1.25
-diff -u -r1.25 sockmisc.c
---- iked/sockmisc.c 11 Aug 2006 20:44:35 -0000 1.25
-+++ iked/sockmisc.c 17 Aug 2007 07:18:52 -0000
-@@ -47,9 +47,15 @@
-
- #ifdef HAVE_NET_PFKEYV2_H
- # include <net/pfkeyv2.h>
--# include <netinet6/ipsec.h>
- #else
- # include <linux/pfkeyv2.h>
-+#endif
-+#ifdef HAVE_NETINET6_IPSEC_H
-+# include <netinet6/ipsec.h>
-+#else
-+# ifdef HAVE_NETIPSEC_IPSEC_H
-+# include <netipsec/ipsec.h>
-+# else
- # include <linux/ipsec.h>
- # ifndef IP_IPSEC_POLICY /* < usagi in.h rev 1.2 / 1.1.1.4 */
- # define IP_IPSEC_POLICY 16 /* <linux/in.h> */
-@@ -60,6 +66,7 @@
- # ifndef PFKEY_UNIT64 /* defined in KAME pfkeyv2.h */
- # define PFKEY_UNIT64(a) ((a) >> 3)
- # endif
-+# endif
- #endif
- #include <netinet/in.h>
-
-Index: iked/ikev1/ikev1.c
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/iked/ikev1/ikev1.c,v
-retrieving revision 1.16
-diff -u -r1.16 ikev1.c
---- iked/ikev1/ikev1.c 25 Jul 2007 12:22:18 -0000 1.16
-+++ iked/ikev1/ikev1.c 17 Aug 2007 07:19:02 -0000
-@@ -51,9 +51,13 @@
- #include <netdb.h>
-
- #ifdef HAVE_NETINET6_IPSEC_H
--# include <netinet6/ipsec.h>
-+# include <netinet6/ipsec.h>
- #else
-+# ifdef HAVE_NETIPSEC_IPSEC_H
-+# include <netipsec/ipsec.h>
-+# else
- # include <linux/ipsec.h>
-+# endif
- #endif
-
- #include "racoon.h"
-Index: iked/ikev1/ipsec_doi.c
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/iked/ikev1/ipsec_doi.c,v
-retrieving revision 1.11
-diff -u -r1.11 ipsec_doi.c
---- iked/ikev1/ipsec_doi.c 24 Jul 2007 07:38:50 -0000 1.11
-+++ iked/ikev1/ipsec_doi.c 17 Aug 2007 07:19:12 -0000
-@@ -40,7 +40,11 @@
- #ifdef HAVE_NETINET6_IPSEC_H
- # include <netinet6/ipsec.h>
- #else
--# include <linux/ipsec.h>
-+# ifdef HAVE_NETIPSEC_IPSEC_H
-+# include <netipsec/ipsec.h>
-+# else
-+# include <linux/ipsec.h>
-+# endif
- #endif
-
- #include <assert.h>
-Index: iked/ikev1/isakmp_inf.c
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/iked/ikev1/isakmp_inf.c,v
-retrieving revision 1.10
-diff -u -r1.10 isakmp_inf.c
---- iked/ikev1/isakmp_inf.c 24 Jul 2007 09:11:54 -0000 1.10
-+++ iked/ikev1/isakmp_inf.c 17 Aug 2007 07:19:12 -0000
-@@ -37,10 +37,15 @@
-
- #include <netinet/in.h>
- #include <sys/queue.h>
-+
- #ifdef HAVE_NETINET6_IPSEC_H
- # include <netinet6/ipsec.h>
- #else
--# include <linux/ipsec.h>
-+# ifdef HAVE_NETIPSEC_IPSEC_H
-+# include <netipsec/ipsec.h>
-+# else
-+# include <linux/ipsec.h>
-+# endif
- #endif
-
- #include <stdlib.h>
-Index: iked/ikev1/isakmp_quick.c
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/iked/ikev1/isakmp_quick.c,v
-retrieving revision 1.10
-diff -u -r1.10 isakmp_quick.c
---- iked/ikev1/isakmp_quick.c 24 Jul 2007 11:19:31 -0000 1.10
-+++ iked/ikev1/isakmp_quick.c 17 Aug 2007 07:19:22 -0000
-@@ -60,8 +60,12 @@
- #ifdef HAVE_NETINET6_IPSEC_H
- # include <netinet6/ipsec.h>
- #else
--# include <linux/ipsec.h>
--#endif
-+# ifdef HAVE_NETIPSEC_IPSEC_H
-+# include <netipsec/ipsec.h>
-+# else
-+# include <linux/ipsec.h>
-+# endif
-+#endif
-
- #include "racoon.h"
-
-Index: iked/ikev1/pfkey.c
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/iked/ikev1/pfkey.c,v
-retrieving revision 1.13
-diff -u -r1.13 pfkey.c
---- iked/ikev1/pfkey.c 9 Aug 2007 12:44:50 -0000 1.13
-+++ iked/ikev1/pfkey.c 17 Aug 2007 07:19:31 -0000
-@@ -63,9 +63,13 @@
-
- #include <netinet/in.h>
- #ifdef HAVE_NETINET6_IPSEC_H
--# include <netinet6/ipsec.h>
-+# include <netinet6/ipsec.h>
- #else
-+# ifdef HAVE_NETIPSEC_IPSEC_H
-+# include <netipsec/ipsec.h>
-+# else
- # include <linux/ipsec.h>
-+# endif
- #endif
- #include <fcntl.h>
-
-Index: iked/ikev1/proposal.c
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/iked/ikev1/proposal.c,v
-retrieving revision 1.8
-diff -u -r1.8 proposal.c
---- iked/ikev1/proposal.c 23 Jul 2007 12:18:12 -0000 1.8
-+++ iked/ikev1/proposal.c 17 Aug 2007 07:19:31 -0000
-@@ -38,9 +38,13 @@
-
- #include <netinet/in.h>
- #ifdef HAVE_NETINET6_IPSEC_H
--# include <netinet6/ipsec.h>
-+# include <netinet6/ipsec.h>
- #else
-+# ifdef HAVE_NETIPSEC_IPSEC_H
-+# include <netipsec/ipsec.h>
-+# else
- # include <linux/ipsec.h>
-+# endif
- #endif
-
- #include <stdlib.h>
-Index: iked/ikev1/strnames.c
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/iked/ikev1/strnames.c,v
-retrieving revision 1.3
-diff -u -r1.3 strnames.c
---- iked/ikev1/strnames.c 12 Dec 2006 10:15:27 -0000 1.3
-+++ iked/ikev1/strnames.c 17 Aug 2007 07:19:40 -0000
-@@ -37,9 +37,13 @@
-
- #include <netinet/in.h>
- #ifdef HAVE_NETINET6_IPSEC_H
--# include <netinet6/ipsec.h>
-+# include <netinet6/ipsec.h>
- #else
-+# ifdef HAVE_NETIPSEC_IPSEC_H
-+# include <netipsec/ipsec.h>
-+# else
- # include <linux/ipsec.h>
-+# endif
- #endif
-
- #include <stdio.h>
-Index: kinkd/base.c
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/kinkd/base.c,v
-retrieving revision 1.185
-diff -u -r1.185 base.c
---- kinkd/base.c 10 Jul 2007 07:57:21 -0000 1.185
-+++ kinkd/base.c 17 Aug 2007 07:19:50 -0000
-@@ -36,7 +36,13 @@
-
- #include <net/pfkeyv2.h>
- #include <netinet/in.h>
--#include <netinet6/ipsec.h>
-+#ifdef HAVE_NETINET6_IPSEC_H
-+# include <netinet6/ipsec.h>
-+#else
-+# ifdef HAVE_NETIPSEC_IPSEC_H
-+# include <netipsec/ipsec.h>
-+# endif
-+#endif
-
- #include <errno.h>
- #include <inttypes.h>
-Index: kinkd/configure
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/kinkd/configure,v
-retrieving revision 1.50
-diff -u -r1.50 configure
---- kinkd/configure 26 Jun 2007 05:43:50 -0000 1.50
-+++ kinkd/configure 17 Aug 2007 07:19:59 -0000
-@@ -1335,6 +1346,6 @@
-
- fi
-
--for ac_hdr in sys/time.h stdarg.h unistd.h krb5/krb5.h krb5.h
-+for ac_hdr in sys/time.h stdarg.h unistd.h krb5/krb5.h krb5.h net/pfkeyv2.h netinet6/ipsec.h netipsec/ipsec.h
- do
- ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
-Index: kinkd/configure.in
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/kinkd/configure.in,v
-retrieving revision 1.53
-diff -u -r1.53 configure.in
---- kinkd/configure.in 26 Jun 2007 05:43:50 -0000 1.53
-+++ kinkd/configure.in 17 Aug 2007 07:19:59 -0000
-@@ -108,7 +108,7 @@
-
- dnl Checks for header files.
- AC_HEADER_STDC
--AC_CHECK_HEADERS(sys/time.h stdarg.h unistd.h krb5/krb5.h krb5.h)
-+AC_CHECK_HEADERS(sys/time.h stdarg.h unistd.h krb5/krb5.h krb5.h net/pfkeyv2.h netinet6/ipsec.h netipsec/ipsec.h)
-
- dnl Checks for typedefs, structures, and compiler characteristics.
- AC_C_CONST
-Index: kinkd/ipsec_doi.c
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/kinkd/ipsec_doi.c,v
-retrieving revision 1.49
-diff -u -r1.49 ipsec_doi.c
---- kinkd/ipsec_doi.c 4 Jul 2007 11:54:48 -0000 1.49
-+++ kinkd/ipsec_doi.c 17 Aug 2007 07:20:09 -0000
-@@ -37,7 +37,13 @@
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
--#include <netinet6/ipsec.h>
-+#ifdef HAVE_NETINET6_IPSEC_H
-+# include <netinet6/ipsec.h>
-+#else
-+# ifdef HAVE_NETIPSEC_IPSEC_H
-+# include <netipsec/ipsec.h>
-+# endif
-+#endif
-
- #include <inttypes.h>
- #include <stdio.h>
-Index: kinkd/sockmisc.c
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/kinkd/sockmisc.c,v
-retrieving revision 1.23
-diff -u -r1.23 sockmisc.c
---- kinkd/sockmisc.c 16 Dec 2005 03:10:17 -0000 1.23
-+++ kinkd/sockmisc.c 17 Aug 2007 07:20:09 -0000
-@@ -38,7 +38,15 @@
- #include <net/if.h>
- #include <net/pfkeyv2.h>
- #include <netinet/in.h>
--#include <netinet6/ipsec.h>
-+#ifdef HAVE_NETINET6_IPSEC_H
-+# include <netinet6/ipsec.h>
-+#else
-+# ifdef HAVE_NETIPSEC_IPSEC_H
-+# include <netipsec/ipsec.h>
-+# else
-+# include <linux/ipsec.h>
-+# endif
-+#endif
-
- #include <errno.h>
- #include <netdb.h>
-Index: lib/configure
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/lib/configure,v
---- lib/configure~ 2007-02-27 21:49:58.000000000 +0900
-+++ lib/configure 2007-08-17 16:27:38.000000000 +0900
-@@ -1517,7 +1517,7 @@
-
- fi
-
--for ac_hdr in sys/time.h net/if_var.h net/ethernet.h limits.h unistd.h stdarg.h varargs.h
-+for ac_hdr in sys/time.h net/if_var.h net/ethernet.h limits.h unistd.h stdarg.h varargs.h netinet6/ipsec.h netipsec/ipsec.h
- do
- ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
- echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-Index: lib/configure.in
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/lib/configure.in,v
-retrieving revision 1.34
-diff -u -r1.34 configure.in
---- lib/configure.in 27 Feb 2007 12:49:58 -0000 1.34
-+++ lib/configure.in 17 Aug 2007 07:20:19 -0000
-@@ -110,7 +110,7 @@
- dnl Checks for header files.
- AC_HEADER_STDC
- AC_HEADER_SYS_WAIT
--AC_CHECK_HEADERS(sys/time.h net/if_var.h net/ethernet.h limits.h unistd.h stdarg.h varargs.h)
-+AC_CHECK_HEADERS(sys/time.h net/if_var.h net/ethernet.h limits.h unistd.h stdarg.h varargs.h netinet6/ipsec.h netipsec/ipsec.h)
-
- RC_CHECK_PFKEYV2_H
- RC_IF_NATT_ENABLE
-Index: lib/if_pfkeyv2.c
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/lib/if_pfkeyv2.c,v
-retrieving revision 1.89
-diff -u -r1.89 if_pfkeyv2.c
---- lib/if_pfkeyv2.c 25 Jul 2007 07:06:24 -0000 1.89
-+++ lib/if_pfkeyv2.c 17 Aug 2007 07:20:30 -0000
-@@ -37,11 +37,18 @@
-
- #ifdef HAVE_NET_PFKEYV2_H
- # include <net/pfkeyv2.h>
--# include <netinet6/ipsec.h>
- #else
- # include <stdint.h>
- # include <linux/pfkeyv2.h>
--# include <linux/ipsec.h>
-+#endif
-+#ifdef HAVE_NETINET6_IPSEC_H
-+# include <netinet6/ipsec.h>
-+#else
-+# ifdef HAVE_NETIPSEC_IPSEC_H
-+# include <netipsec/ipsec.h>
-+# else
-+# include <linux/ipsec.h>
-+# endif
- #endif
- #include "pfkeyv2aux.h"
- #include <netinet/in.h>
-Index: lib/rc_type.c
-===================================================================
-RCS file: /anoncvs/racoon2/racoon2/lib/rc_type.c,v
-retrieving revision 1.21
-diff -u -r1.21 rc_type.c
---- lib/rc_type.c 11 Aug 2006 15:44:42 -0000 1.21
-+++ lib/rc_type.c 17 Aug 2007 07:20:30 -0000
-@@ -34,11 +34,18 @@
-
- #ifdef HAVE_NET_PFKEYV2_H
- # include <net/pfkeyv2.h>
--# include <netinet6/ipsec.h>
- #else
- # include <stdint.h>
- # include <linux/pfkeyv2.h>
--# include <linux/ipsec.h>
-+#endif
-+#ifdef HAVE_NETINET6_IPSEC_H
-+# include <netinet6/ipsec.h>
-+#else
-+# ifdef HAVE_NETIPSEC_IPSEC_H
-+# include <netipsec/ipsec.h>
-+# else
-+# include <linux/ipsec.h>
-+# endif
- #endif
- #include "pfkeyv2aux.h"
- #include <netinet/in.h>
diff --git a/security/racoon2/files/patch-rcvar b/security/racoon2/files/patch-rcvar
deleted file mode 100644
index d736146fbfc6..000000000000
--- a/security/racoon2/files/patch-rcvar
+++ /dev/null
@@ -1,33 +0,0 @@
---- samples/rc.d-iked.in.orig Tue Feb 7 02:19:19 2006
-+++ samples/rc.d-iked.in Tue Feb 7 02:19:19 2006
-@@ -14,7 +14,7 @@
- exec_prefix=@exec_prefix@
-
- name="iked"
--rcvar=$name
-+rcvar=`set_rcvar`
- command="@sbindir@/${name}"
- extra_commands="reload"
- required_vars="spmd"
---- samples/rc.d-kinkd.in.orig Tue Feb 7 02:19:19 2006
-+++ samples/rc.d-kinkd.in Tue Feb 7 02:19:19 2006
-@@ -14,7 +14,7 @@
- exec_prefix=@exec_prefix@
-
- name="kinkd"
--rcvar=$name
-+rcvar=`set_rcvar`
- command="@sbindir@/${name}"
- extra_commands="reload"
- required_vars="spmd"
---- samples/rc.d-spmd.in.orig Tue Feb 7 02:19:19 2006
-+++ samples/rc.d-spmd.in Tue Feb 7 02:19:19 2006
-@@ -13,7 +13,7 @@
- exec_prefix=@exec_prefix@
-
- name="spmd"
--rcvar=$name
-+rcvar=`set_rcvar`
- command="@sbindir@/${name}"
- extra_commands="reload"
- pidfile="/var/run/${name}.pid"
diff --git a/security/racoon2/files/patch-samples-Makefile.in b/security/racoon2/files/patch-samples-Makefile.in
index 0400668aea7a..6657df003905 100644
--- a/security/racoon2/files/patch-samples-Makefile.in
+++ b/security/racoon2/files/patch-samples-Makefile.in
@@ -1,18 +1,29 @@
---- samples/Makefile.in.orig Tue Nov 8 05:53:50 2005
-+++ samples/Makefile.in Sat Jul 15 17:50:25 2006
-@@ -18,10 +18,11 @@
+--- samples/Makefile.in.orig 2007-12-27 10:08:52.000000000 +0900
++++ samples/Makefile.in 2008-04-17 15:19:17.000000000 +0900
+@@ -2,7 +2,7 @@
+
+ srcdir=@srcdir@
+ prefix=@prefix@
+-sysconfdir=@sysconfdir@/racoon2
++sysconfdir=@sysconfdir@
+ INSTALL =@INSTALL@ @INSTALL_OPTS@
+ INSTALL_PROGRAM=@INSTALL_PROGRAM@
+ INSTALL_DATA=@INSTALL_DATA@
+@@ -29,11 +29,12 @@
+ $(INSTALL) -d -m 700 $(sysconfdir)/cert
install-startup-rc-d:
- $(INSTALL) -d $(sysconfdir)/rc.d
+- $(INSTALL) -d $(sysconfdir)/rc.d
- $(INSTALL_SCRIPT) rc.d-iked $(sysconfdir)/rc.d/iked
- $(INSTALL_SCRIPT) rc.d-kinkd $(sysconfdir)/rc.d/kinkd
- $(INSTALL_SCRIPT) rc.d-spmd $(sysconfdir)/rc.d/spmd
- $(INSTALL_SCRIPT) rc.d-racoon2 $(sysconfdir)/rc.d/racoon2
-+ $(INSTALL_SCRIPT) rc.d-iked $(sysconfdir)/rc.d/iked.sh
++ $(INSTALL) -d $(startupdir)/rc.d
++ $(INSTALL_SCRIPT) rc.d-iked $(prefix)/etc/rc.d/iked
+.if defined (WITH_KINK)
-+ $(INSTALL_SCRIPT) rc.d-kinkd $(sysconfdir)/rc.d/kinkd.sh
++ $(INSTALL_SCRIPT) rc.d-kinkd $(prefix)/etc/rc.d/kinkd
+.endif
-+ $(INSTALL_SCRIPT) rc.d-spmd $(sysconfdir)/rc.d/spmd.sh
++ $(INSTALL_SCRIPT) rc.d-spmd $(prefix)/etc/rc.d/spmd
install-startup-init-d:
$(INSTALL) -d $(sysconfdir)/init.d
diff --git a/security/racoon2/files/patch-samples-rc.d-iked.in b/security/racoon2/files/patch-samples-rc.d-iked.in
index a6a470c9d414..0aedae7a2dcd 100644
--- a/security/racoon2/files/patch-samples-rc.d-iked.in
+++ b/security/racoon2/files/patch-samples-rc.d-iked.in
@@ -1,7 +1,11 @@
---- samples/rc.d-iked.in.orig Fri Oct 28 15:33:16 2005
-+++ samples/rc.d-iked.in Wed Jun 7 16:03:18 2006
-@@ -17,7 +17,7 @@
- rcvar=$name
+--- samples/rc.d-iked.in.orig 2005-10-28 15:33:16.000000000 +0900
++++ samples/rc.d-iked.in 2008-04-17 15:11:55.000000000 +0900
+@@ -14,10 +14,10 @@
+ exec_prefix=@exec_prefix@
+
+ name="iked"
+-rcvar=$name
++rcvar=`set_rcvar`
command="@sbindir@/${name}"
extra_commands="reload"
-required_vars="spmd"
diff --git a/security/racoon2/files/patch-samples-rc.d-kinkd.in b/security/racoon2/files/patch-samples-rc.d-kinkd.in
index a15efa66c8d1..7200054e53cf 100644
--- a/security/racoon2/files/patch-samples-rc.d-kinkd.in
+++ b/security/racoon2/files/patch-samples-rc.d-kinkd.in
@@ -1,7 +1,11 @@
---- samples/rc.d-kinkd.in~ Sun Jul 16 00:23:47 2006
-+++ samples/rc.d-kinkd.in Tue Jul 18 01:20:34 2006
-@@ -17,7 +17,7 @@
- rcvar=`set_rcvar`
+--- samples/rc.d-kinkd.in.orig 2005-10-28 15:33:16.000000000 +0900
++++ samples/rc.d-kinkd.in 2008-04-17 15:11:55.000000000 +0900
+@@ -14,10 +14,10 @@
+ exec_prefix=@exec_prefix@
+
+ name="kinkd"
+-rcvar=$name
++rcvar=`set_rcvar`
command="@sbindir@/${name}"
extra_commands="reload"
-required_vars="spmd"
diff --git a/security/racoon2/files/patch-samples-rc.d-spmd.in b/security/racoon2/files/patch-samples-rc.d-spmd.in
new file mode 100644
index 000000000000..7260892b5ef6
--- /dev/null
+++ b/security/racoon2/files/patch-samples-rc.d-spmd.in
@@ -0,0 +1,11 @@
+--- samples/rc.d-spmd.in.orig 2007-07-11 09:59:30.000000000 +0900
++++ samples/rc.d-spmd.in 2008-04-17 15:11:55.000000000 +0900
+@@ -13,7 +13,7 @@
+ exec_prefix=@exec_prefix@
+
+ name="spmd"
+-rcvar=$name
++rcvar=`set_rcvar`
+ command="@sbindir@/${name}"
+ extra_commands="reload"
+ pidfile="/var/run/${name}.pid"