aboutsummaryrefslogtreecommitdiff
path: root/security/racoon2/files
diff options
context:
space:
mode:
Diffstat (limited to 'security/racoon2/files')
-rw-r--r--security/racoon2/files/patch-aa20
-rw-r--r--security/racoon2/files/patch-ab22
-rw-r--r--security/racoon2/files/patch-ac11
-rw-r--r--security/racoon2/files/patch-ad13
-rw-r--r--security/racoon2/files/patch-crypto_openssl.c42
-rw-r--r--security/racoon2/files/racoon.sh42
6 files changed, 0 insertions, 150 deletions
diff --git a/security/racoon2/files/patch-aa b/security/racoon2/files/patch-aa
deleted file mode 100644
index b9e78afe4ac3..000000000000
--- a/security/racoon2/files/patch-aa
+++ /dev/null
@@ -1,20 +0,0 @@
---- ../libipsec/Makefile.orig Sun Jun 11 23:54:31 2000
-+++ ../libipsec/Makefile Tue Oct 17 01:06:10 2000
-@@ -25,12 +25,13 @@
- # OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
- # SUCH DAMAGE.
-
--.if exists(${.CURDIR}/../Makefile.opsys)
--.include "${.CURDIR}/../Makefile.opsys"
--.endif
-+#.if exists(${.CURDIR}/../Makefile.opsys)
-+#.include "${.CURDIR}/../Makefile.opsys"
-+#.endif
-+OPSYS!= uname -s
-
- LIB= ipsec
--CFLAGS+=-g
-+CFLAGS+=-g -I.
- .if (${OPSYS} != "NetBSD")
- CFLAGS+=-DIPSEC_DEBUG -DIPSEC -DINET6
- .else
diff --git a/security/racoon2/files/patch-ab b/security/racoon2/files/patch-ab
deleted file mode 100644
index e5fb29c03f60..000000000000
--- a/security/racoon2/files/patch-ab
+++ /dev/null
@@ -1,22 +0,0 @@
---- Makefile.in.orig Fri Sep 27 07:04:59 2002
-+++ Makefile.in Thu Nov 21 22:28:50 2002
-@@ -7,7 +7,7 @@
- LDFLAGS=@LDFLAGS@
- CPPFLAGS= @CPPFLAGS@
- OPTFLAG=@OPTFLAG@
--CFLAGS= @CFLAGS@ $(CPPFLAGS) @DEFS@ $(CPPFLAGS) $(OPTFLAG) -DIPSEC -I. -I$(srcdir) -DSYSCONFDIR=\"${sysconfdir}\"
-+CFLAGS= @CFLAGS@ $(CPPFLAGS) @DEFS@ $(CPPFLAGS) $(OPTFLAG) -DIPSEC -I. -I$(srcdir) -DSYSCONFDIR=\"${sysconfdir}/racoon\"
- CFLAGS+=-DYY_NO_UNPUT
- CFLAGS+=-I${srcdir}/../libipsec
- LIBS= @LIBS@
-@@ -88,10 +88,6 @@
- $(INSTALL) -o bin -g bin -m 444 racoon.conf.5 $(mandir)/man5
- -mkdir -p ${sysconfdir}/racoon
- for i in $(CONF); do \
-- if test ! -f ${sysconfdir}/racoon/$$i; then \
-- $(INSTALL) -o bin -g bin -m 444 samples/$$i \
-- ${sysconfdir}/racoon; \
-- fi; \
- $(INSTALL) -o bin -g bin -m 444 samples/$$i \
- ${sysconfdir}/racoon/$$i.dist; \
- done
diff --git a/security/racoon2/files/patch-ac b/security/racoon2/files/patch-ac
deleted file mode 100644
index ee9eba403dd1..000000000000
--- a/security/racoon2/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure- Wed Jul 5 16:18:19 2000
-+++ configure Wed Jul 5 16:18:32 2000
-@@ -4021,7 +4021,7 @@
-
- cat >> $CONFIG_STATUS <<EOF
-
--CONFIG_FILES=\${CONFIG_FILES-"Makefile samples/psk.txt samples/racoon.conf"}
-+CONFIG_FILES=\${CONFIG_FILES-"Makefile samples/psk.txt samples/racoon.conf racoon.8"}
- EOF
- cat >> $CONFIG_STATUS <<\EOF
- for ac_file in .. $CONFIG_FILES; do if test "x$ac_file" != x..; then
diff --git a/security/racoon2/files/patch-ad b/security/racoon2/files/patch-ad
deleted file mode 100644
index 8b8fb3b81fe0..000000000000
--- a/security/racoon2/files/patch-ad
+++ /dev/null
@@ -1,13 +0,0 @@
---- racoon.8.in.orig Tue Jul 4 21:27:59 2000
-+++ racoon.8.in Wed Jul 5 16:17:43 2000
-@@ -97,8 +97,8 @@
- .El
- .\"
- .Sh FILES
--.Bl -tag -width /usr/local/v6/etc/racoon.conf -compact
--.It Pa /usr/local/v6/etc/racoon.conf
-+.Bl -tag -width @sysconfdir@/racoon/racoon.conf -compact
-+.It Pa @sysconfdir@/racoon/racoon.conf
- default configuration file.
- .It Pa /var/log/racoon.log
- default log file.
diff --git a/security/racoon2/files/patch-crypto_openssl.c b/security/racoon2/files/patch-crypto_openssl.c
deleted file mode 100644
index 3f243d19c8e2..000000000000
--- a/security/racoon2/files/patch-crypto_openssl.c
+++ /dev/null
@@ -1,42 +0,0 @@
---- crypto_openssl.old.c 2004-04-09 22:25:56.000000000 +0530
-+++ crypto_openssl.c 2004-08-02 20:30:03.000000000 +0530
-@@ -1654,6 +1654,7 @@
-
- HMAC_Final((HMAC_CTX *)c, res->v, &l);
- res->l = l;
-+ HMAC_cleanup((HMAC_CTX *)c);
- (void)racoon_free(c);
-
- if (SHA512_DIGEST_LENGTH != res->l) {
-@@ -1710,6 +1711,7 @@
-
- HMAC_Final((HMAC_CTX *)c, res->v, &l);
- res->l = l;
-+ HMAC_cleanup((HMAC_CTX *)c);
- (void)racoon_free(c);
-
- if (SHA384_DIGEST_LENGTH != res->l) {
-@@ -1766,6 +1768,7 @@
-
- HMAC_Final((HMAC_CTX *)c, res->v, &l);
- res->l = l;
-+ HMAC_cleanup((HMAC_CTX *)c);
- (void)racoon_free(c);
-
- if (SHA256_DIGEST_LENGTH != res->l) {
-@@ -1823,6 +1826,7 @@
-
- HMAC_Final((HMAC_CTX *)c, res->v, &l);
- res->l = l;
-+ HMAC_cleanup((HMAC_CTX *)c);
- (void)racoon_free(c);
-
- if (SHA_DIGEST_LENGTH != res->l) {
-@@ -1879,6 +1883,7 @@
-
- HMAC_Final((HMAC_CTX *)c, res->v, &l);
- res->l = l;
-+ HMAC_cleanup((HMAC_CTX *)c);
- (void)racoon_free(c);
-
- if (MD5_DIGEST_LENGTH != res->l) {
diff --git a/security/racoon2/files/racoon.sh b/security/racoon2/files/racoon.sh
deleted file mode 100644
index ecde585dad87..000000000000
--- a/security/racoon2/files/racoon.sh
+++ /dev/null
@@ -1,42 +0,0 @@
-#!/bin/sh
-
-# Start or stop racoon
-# $FreeBSD$
-
-# PROVIDE: racoon
-# REQUIRE: DAEMON
-# BEFORE: LOGIN
-# KEYWORD: FreeBSD shutdown
-#
-# NOTE for FreeBSD 5.0+:
-# If you want this script to start with the base rc scripts
-# move racoon.sh to /etc/rc.d/racoon
-
-prefix=%%PREFIX%%
-
-# Define these racoon_* variables in one of these files:
-# /etc/rc.conf
-# /etc/rc.conf.local
-# /etc/rc.conf.d/racoon
-#
-# DO NOT CHANGE THESE DEFAULT VALUES HERE
-#
-[ -z "$racoon_enable" ] && racoon_enable="YES" # Enable racoon
-#racoon_program="${prefix}/sbin/racoon" # Location of racoon
-#racoon_flags="" # Flags to racoon program
-
-. %%RC_SUBR%%
-
-name="racoon"
-rcvar=`set_rcvar`
-command="${prefix}/sbin/racoon"
-pidfile="/var/run/racoon.pid"
-required_files="${prefix}/etc/racoon/racoon.conf"
-stop_postcmd="racoon_poststop"
-
-racoon_poststop() {
- /bin/rm -f ${pidfile}
-}
-
-load_rc_config $name
-run_rc_command "$1"