aboutsummaryrefslogtreecommitdiff
path: root/security/razorback-scriptNugget
diff options
context:
space:
mode:
Diffstat (limited to 'security/razorback-scriptNugget')
-rw-r--r--security/razorback-scriptNugget/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/security/razorback-scriptNugget/Makefile b/security/razorback-scriptNugget/Makefile
index a2121c36cabd..27681e25d2ab 100644
--- a/security/razorback-scriptNugget/Makefile
+++ b/security/razorback-scriptNugget/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: razorback-scriptNugget
-# Date created: 2011/06/8
-# Whom: Tom Judge <tom@tomjudge.com>
-#
+# Created by: Tom Judge <tom@tomjudge.com>
# $FreeBSD$
-#
PORTNAME= scriptNugget
PORTVERSION= 0.5.0
@@ -26,9 +22,8 @@ RUN_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-master
OPTIONS_DEFINE= DEBUG ASSERT
ASSERT_DESC= Enable Asserts
-.include <bsd.port.options.mk>
-
RB_LIBDIR?= ${PREFIX}/lib/razorback
+USES= pkgconfig
USE_GNOME= libxml2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-ruby
@@ -37,6 +32,8 @@ USE_LDCONFIG= ${RB_LIBDIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.include <bsd.port.options.mk>
+
.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--enable-debug
.endif