aboutsummaryrefslogtreecommitdiff
path: root/security/regripper/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/regripper/Makefile')
-rw-r--r--security/regripper/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/security/regripper/Makefile b/security/regripper/Makefile
index 7784ace47542..113a3ab2562a 100644
--- a/security/regripper/Makefile
+++ b/security/regripper/Makefile
@@ -16,14 +16,15 @@ RUN_DEPENDS= p5-Parse-Win32Registry>=0:${PORTSDIR}/devel/p5-Parse-Win32Registry
NO_WRKSUBDIR= yes
NO_BUILD= yes
-USES= dos2unix perl5 zip
+USES= dos2unix perl5 zip shebangfix
+SHEBANG_FILES= rip.pl
+perl_OLD_CMD= c:\\\\perl\\\\bin\\\\perl.exe
USE_PERL5= run
PLIST_FILES= bin/rip.pl
post-patch:
- ${REINPLACE_CMD} -e 's|#! c:\\perl\\bin\\perl.exe|#!${PERL}| ; \
- s|plugindir = $$str|plugindir = "${DATADIR}"| ; \
+ ${REINPLACE_CMD} -e 's|plugindir = $$str|plugindir = "${DATADIR}"| ; \
s|require "plugins/|require "${DATADIR}plugins/|' ${WRKSRC}/rip.pl
do-install: