aboutsummaryrefslogtreecommitdiff
path: root/security/seahorse-plugins/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/seahorse-plugins/Makefile')
-rw-r--r--security/seahorse-plugins/Makefile84
1 files changed, 84 insertions, 0 deletions
diff --git a/security/seahorse-plugins/Makefile b/security/seahorse-plugins/Makefile
new file mode 100644
index 000000000000..bf3507e2fff6
--- /dev/null
+++ b/security/seahorse-plugins/Makefile
@@ -0,0 +1,84 @@
+# New ports collection makefile for: seahorse-plugins
+# Date created: 06 August 2008
+# Whom: Dave McKay <dave@mu.org>
+#
+# $FreeBSD$
+# $MCom: ports/security/seahorse-plugins/Makefile,v 1.4 2008/10/20 03:02:56 mezz Exp $
+#
+
+PORTNAME= seahorse-plugins
+PORTVERSION= 2.24.1
+CATEGORIES= security gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Plug-ins for the Seahorse key and password management application
+
+LIB_DEPENDS= cryptui.0:${PORTSDIR}/security/seahorse
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GECKO= firefox xulrunner
+USE_GNOME= gnomehack intlhack gnomeprefix libglade2 gconf2 gnomedocutils
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+INSTALLS_OMF= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+OPTIONS= EPIPHANY "Enable Epiphany plug-in support" on \
+ NAUTILUS "Enable the Nautilus component" on \
+ GEDIT "Enable GEdit plug-in support" on \
+ APPLET "Enable clipboard encryption applet" on
+
+GCONF_SCHEMAS= seahorse-plugins.schemas
+MAN1= seahorse-agent.1 seahorse-tool.1
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GEDIT)
+BUILD_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
+RUN_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
+PLIST_SUB+= GEDIT=""
+GCONF_SCHEMAS+= seahorse-gedit.schemas
+.else
+PLIST_SUB+= GEDIT="@comment "
+CONFIGURE_ARGS+=--disable-gedit
+.endif
+
+.if !defined(WITHOUT_NAUTILUS)
+USE_GNOME+= nautilus2
+PLIST_SUB+= NAUTILUS=""
+.else
+PLIST_SUB+= NAUTILUS="@comment "
+CONFIGURE_ARGS+=--disable-nautilus
+.endif
+
+.if !defined(WITHOUT_EPIPHANY)
+BUILD_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
+RUN_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
+PLIST_SUB+= EPIPHANY="" EPHY_VERSION="2.23"
+.else
+CONFIGURE_ARGS+=--disable-epiphany
+PLIST_SUB+= EPHY="@comment "
+.endif
+
+.if !defined(WITHOUT_APPLET)
+USE_GNOME+= gnomepanel
+PLIST_SUB+= APPLET=""
+.else
+CONFIGURE_ARGS+=--disable-applet
+PLIST_SUB+= APPLET="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|" == "|" = "|g' \
+ ${WRKSRC}/configure
+
+post-install:
+ @-update-desktop-database
+ @-update-mime-database ${PREFIX}/share/mime
+
+.include <bsd.port.post.mk>