aboutsummaryrefslogtreecommitdiff
path: root/security/seahorse/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/seahorse/Makefile')
-rw-r--r--security/seahorse/Makefile55
1 files changed, 5 insertions, 50 deletions
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index b6aa77eb52d5..0b5e7cd21ef2 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -3,11 +3,11 @@
# Whom: Dave McKay <dave@mu.org>
#
# $FreeBSD$
-# $MCom: ports/security/seahorse/Makefile,v 1.61 2008/03/14 14:13:03 mezz Exp $
+# $MCom: ports/security/seahorse/Makefile,v 1.73 2008/11/24 02:44:50 marcus Exp $
#
PORTNAME= seahorse
-PORTVERSION= 2.22.3
+PORTVERSION= 2.24.1
PORTREVISION= 1
CATEGORIES= security gnome
MASTER_SITES= GNOME
@@ -26,47 +26,23 @@ USE_LDCONFIG= yes
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GECKO= firefox xulrunner firefox-devel<->firefox
-USE_GNOME= gnomehack intlhack gnomeprefix libgnomeui
+USE_GNOME= gnomehack intlhack gnomeprefix libglade2 gconf2 gnomedocutils
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
-CONFIGURE_ARGS= --with-gecko=${GECKO}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= seahorse.schemas
-MAN1= seahorse-agent.1 seahorse-daemon.1 seahorse-tool.1
+MAN1= seahorse-daemon.1
OPTIONS= LDAP "Enable LDAP support" on \
HKP "Enable HKP keyserver interface" on \
NOTIFY "Enable libnotify support" on \
- APPLET "Enable clipboard encryption applet" on \
- MDNS "Enable mDNS key sharing" on \
- GEDIT "Enable GEdit plug-in support" on \
- NAUTILUS "Enable the Nautilus component" on \
- EPIPHANY "Enable Epiphany plug-in support" on
+ MDNS "Enable mDNS key sharing" on
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_GEDIT)
-BUILD_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
-RUN_DEPENDS+= gedit:${PORTSDIR}/editors/gedit
-PLIST_SUB+= GEDIT=""
-GCONF_SCHEMAS+= seahorse-gedit.schemas
-.else
-PLIST_SUB+= GEDIT="@comment "
-CONFIGURE_ARGS+=--disable-gedit
-.endif
-
-.if !defined(WITHOUT_NAUTILUS)
-USE_GNOME+= nautilus2
-PLIST_SUB+= NAUTILUS=""
-.else
-PLIST_SUB+= NAUTILUS="@comment "
-CONFIGURE_ARGS+=--disable-nautilus
-.endif
-
.if !defined(WITHOUT_LDAP)
USE_OPENLDAP= yes
.else
@@ -85,23 +61,6 @@ LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+=--disable-libnotify
.endif
-.if !defined(WITHOUT_EPIPHANY)
-BUILD_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
-RUN_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
-PLIST_SUB+= EPHY="" EPHY_VERSION="2.22"
-.else
-CONFIGURE_ARGS+=--disable-epiphany
-PLIST_SUB+= EPHY="@comment "
-.endif
-
-.if !defined(WITHOUT_APPLET)
-USE_GNOME+= gnomepanel
-PLIST_SUB+= APPLET=""
-.else
-CONFIGURE_ARGS+=--disable-applet
-PLIST_SUB+= APPLET="@comment "
-.endif
-
.if !defined(WITHOUT_MDNS)
LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi-app
.else
@@ -112,8 +71,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|" == "|" = "|g' \
${WRKSRC}/configure
-post-install:
- -@update-desktop-database
-
-.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
.include <bsd.port.post.mk>