aboutsummaryrefslogtreecommitdiff
path: root/security/sectok
diff options
context:
space:
mode:
Diffstat (limited to 'security/sectok')
-rw-r--r--security/sectok/Makefile1
-rw-r--r--security/sectok/files/patch-cyberflex.c2
2 files changed, 2 insertions, 1 deletions
diff --git a/security/sectok/Makefile b/security/sectok/Makefile
index 2d464d19b29e..71241295772e 100644
--- a/security/sectok/Makefile
+++ b/security/sectok/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sectok
PORTVERSION= 20030825
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.citi.umich.edu/projects/smartcard/
EXTRACT_SUFX= .tgz
diff --git a/security/sectok/files/patch-cyberflex.c b/security/sectok/files/patch-cyberflex.c
index f5889c1ed600..5dbbf31f50a5 100644
--- a/security/sectok/files/patch-cyberflex.c
+++ b/security/sectok/files/patch-cyberflex.c
@@ -10,7 +10,7 @@
+#define SHA1Init SHA1_Init
+#define SHA1Update SHA1_Update
+#define SHA1Final SHA1_Final
-+#include <sha.h>
++#include <openssl/sha.h>
+#else
#include <sha1.h>
#endif