aboutsummaryrefslogtreecommitdiff
path: root/security/softhsm2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/softhsm2/Makefile')
-rw-r--r--security/softhsm2/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/security/softhsm2/Makefile b/security/softhsm2/Makefile
index 54d833bb93fa..a67e7b75db2d 100644
--- a/security/softhsm2/Makefile
+++ b/security/softhsm2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= softhsm
PORTVERSION= 2.4.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://dist.opendnssec.org/source/ \
http://dist.opendnssec.org/source/testing/
@@ -26,9 +27,11 @@ USE_LDCONFIG= yes
LIB_DEPENDS+= libcppunit.so:devel/cppunit
-OPTIONS_DEFINE= SQLITE
+OPTIONS_DEFINE= SQLITE MIGRATE
+MIGRATE_IMPLIES= SQLITE
OPTIONS_SUB= yes
SQLITE_DESC= Build with object store backend DB support (SQLITE3)
+MIGRATE_DESC= Build the migration tool
OPTIONS_SINGLE= CRYP
OPTIONS_SINGLE_CRYP= CRYP_OPEN CRYP_BOTAN
@@ -36,10 +39,11 @@ OPTIONS_SINGLE_CRYP= CRYP_OPEN CRYP_BOTAN
CRYP_OPEN_DESC= Build with OpenSSL crypto library
CRYP_BOTAN_DESC= Build with Botan crypto library
-OPTIONS_DEFAULT= CRYP_OPEN
+OPTIONS_DEFAULT= CRYP_OPEN SQLITE MIGRATE
SQLITE_CONFIGURE_WITH= sqlite3=${LOCALBASE} objectstore-backend-db
SQLITE_USES= sqlite
+MIGRATE_CONFIGURE_WITH= migrate
CRYP_BOTAN_CONFIGURE_ON= --with-crypto-backend=botan
CRYP_BOTAN_LIB_DEPENDS= libbotan-1.10.so:security/botan110