aboutsummaryrefslogtreecommitdiff
path: root/security/ssh/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/ssh/Makefile')
-rw-r--r--security/ssh/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index bc1cdd8a6db3..6649c29ff18a 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -3,7 +3,7 @@
# Date created: 30 Jul 1995
# Whom: torstenb@FreeBSD.ORG
#
-# $Id: Makefile,v 1.70 1998/10/08 13:11:52 asami Exp $
+# $Id: Makefile,v 1.71 1998/10/30 06:15:18 obrien Exp $
#
# Maximal ssh package requires YES values for
# USE_PERL, USE_TCPWRAP
@@ -128,13 +128,11 @@ post-install:
chmod 751 ${PREFIX}/etc/rc.d/sshd.sh; \
fi
-.include <bsd.port.mk>
-
-# Following stuff must be after <bsd.port.mk> to expand exists() properly
+.include <bsd.port.pre.mk>
.if defined(USE_PERL) && ${USE_PERL} == YES || \
exists(${PERL5}) && (!defined(USE_PERL) || ${USE_PERL} != NO)
-BUILD_DEPENDS+= perl${PERL_VERSION}:${PORTSDIR}/lang/perl5
+USE_PERL5= yes
CONFIGURE_ENV+= PERL=${PERL5}
.else
CONFIGURE_ENV+= PERL=/replace_it_with_PERL_path
@@ -153,3 +151,5 @@ LIB_DEPENDS+= wrap.7:${PORTSDIR}/security/tcp_wrapper
.if defined(USE_SOCKS) && ${USE_SOCKS} == YES
CONFIGURE_ARGS+= --with-socks="-L${PREFIX}/lib -lsocks5" --with-socks5
.endif
+
+.include <bsd.port.post.mk>