aboutsummaryrefslogtreecommitdiff
path: root/security/ssh2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/ssh2/Makefile')
-rw-r--r--security/ssh2/Makefile43
1 files changed, 25 insertions, 18 deletions
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index 07073a77edbc..03d92264ea5e 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -6,23 +6,28 @@
#
PORTNAME= ssh2
-PORTVERSION= 2.3.0
+PORTVERSION= 3.1.0
CATEGORIES= security
MASTER_SITES= ftp://ftp.ssh.com/pub/ssh/ \
ftp://sunsite.unc.edu/pub/packages/security/ssh/ \
- ftp://ftp.kyoto.wide.ad.jp/pub/security/ssh/
+ ftp://ftp.kyoto.wide.ad.jp/pub/security/ssh/ \
+ ftp://ftp.cis.fed.gov/pub/ssh/ \
+ ftp://ftp.keystealth.org/pub/ssh/ \
+ ftp://mirror.chpc.utah.edu/pub/ssh/ \
+ ftp://metalab.unc.edu/pub/packages/security/ssh/ \
+ ftp://herbie.ucs.indiana.edu/pub/security/ssh/
DISTNAME= ssh-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= larse@ISI.EDU
#RESTRICTED= "Crypto; export-controlled"
GNU_CONFIGURE= YES
-CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --disable-compiler-optimizations
+CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc/ssh2
#Uncomment if all your users are in their own group and their homedir
#is writeable by that group. Beware the security implications!
-#CONFIGURE_ARGS+= --enable-group-writeability
+#CONFIGURE_ARGS+= --enable-group-writeability
.include <bsd.port.pre.mk>
@@ -30,28 +35,30 @@ CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --disable-compiler-optimizations
#WITH_TCPWRAP= yes
.if exists(/usr/include/tcpd.h) && !defined(WITHOUT_TCPWRAP)
-CONFIGURE_ARGS+= --with-libwrap
+CONFIGURE_ARGS+= --with-libwrap
.elif defined(WITH_TCPWRAP)
-CONFIGURE_ARGS+= --with-libwrap="-L ${PREFIX}/lib -lwrap"
+CONFIGURE_ARGS+= --with-libwrap="-L${LOCALBASE}/lib -lwrap"
LIB_DEPENDS+= wrap.7:${PORTSDIR}/security/tcp_wrapper
.endif
-MAN1= scp.1 sftp.1 scp2.1 sftp2.1 sshregex.1 ssh-probe2.1 ssh-dummy-shell.1 \
- ssh-pubkeymgr.1 ssh2.1 ssh-chrootmgr.1 ssh-agent.1 ssh-keygen.1 \
- ssh-add.1 ssh-add2.1 ssh-agent2.1 ssh-keygen2.1
-MAN5= ssh2_config.5 sshd2_config.5
-MAN8= sshd.8 sshd2.8
+MAN1= ssh2.1 ssh-keygen2.1 ssh-add2.1 ssh-agent2.1 scp2.1 sftp2.1 \
+ sshregex.1 ssh-probe2.1 ssh-dummy-shell.1 ssh-pubkeymgr.1 \
+ ssh-chrootmgr.1
+MAN5= ssh2_config.5 sshd-check-conf.5 sshd2_config.5
+MAN8= sshd2.8
+MLINKS= ssh2.1 ssh.1 ssh-add2.1 ssh-add.1 ssh-agent2.1 ssh-agent.1 \
+ ssh-keygen2.1 ssh-keygen.1 scp2.1 scp.1 sftp2.1 sftp.1 \
+ ssh-probe2.1 ssh-probe.1 sshd2.8 sshd.8
+MANCOMPRESSED= no
-PORTDOCS= BUG.REPORT CHANGES FAQ INSTALL LICENSE README \
- SSH2.QUICKSTART
+PORTDOCS= BUG.REPORT CHANGES FAQ INSTALL LICENSE MANIFEST NEWS README \
+ REGEX-SYNTAX SSH2.QUICKSTART
post-install:
- ${RM} ${PREFIX}/man/man1/ssh.1
- ${RM} ${PREFIX}/man/man1/ssh-probe.1
.if !defined(NOPORTDOCS)
- -${MKDIR} ${PREFIX}/share/doc/ssh2
+ ${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/doc/ssh2
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
.endfor
.endif
#