aboutsummaryrefslogtreecommitdiff
path: root/security/ssh2
diff options
context:
space:
mode:
Diffstat (limited to 'security/ssh2')
-rw-r--r--security/ssh2/files/patch-ab34
-rw-r--r--security/ssh2/files/patch-ac205
-rw-r--r--security/ssh2/files/patch-af67
-rw-r--r--security/ssh2/files/patch-aj15
4 files changed, 213 insertions, 108 deletions
diff --git a/security/ssh2/files/patch-ab b/security/ssh2/files/patch-ab
index 320d136cc615..fba5d6ebf0ea 100644
--- a/security/ssh2/files/patch-ab
+++ b/security/ssh2/files/patch-ab
@@ -1,5 +1,20 @@
-*** configure.orig Fri Oct 4 17:00:44 1996
---- configure Wed Oct 16 06:32:03 1996
+*** configure.old Tue Oct 22 02:36:46 1996
+--- configure Tue Oct 22 02:40:51 1996
+***************
+*** 1302,1313 ****
+ ;;
+ esac
+
+- # Socket pairs appear to be broken on several systems. I don't know exactly
+- # where, so I'll use pipes everywhere for now.
+- cat >> confdefs.h <<\EOF
+- #define USE_PIPES 1
+- EOF
+-
+
+ echo $ac_n "checking that the compiler works""... $ac_c" 1>&6
+ if test "$cross_compiling" = yes; then
+--- 1302,1307 ----
***************
*** 5092,5098 ****
EOF
@@ -9,11 +24,22 @@
EOF
cat >> $CONFIG_STATUS <<\EOF
for ac_file in .. $CONFIG_FILES; do if test "x$ac_file" != x..; then
---- 5092,5098 ----
+--- 5086,5092 ----
EOF
cat >> $CONFIG_STATUS <<EOF
-! CONFIG_FILES=\${CONFIG_FILES-"Makefile sshd.8 ssh.1 make-ssh-known-hosts.1 make-ssh-known-hosts.pl zlib-1.0.3/Makefile"}
+! CONFIG_FILES=\${CONFIG_FILES-"Makefile sshd.8 ssh.1 make-ssh-known-hosts.1 make-ssh-known-hosts.pl"}
EOF
cat >> $CONFIG_STATUS <<\EOF
for ac_file in .. $CONFIG_FILES; do if test "x$ac_file" != x..; then
+***************
+*** 5284,5289 ****
+--- 5278,5285 ----
+ done
+
+ for ac_config_dir in gmp-2.0.2; do
++
++ continue # XXX don't configure gmp
+
+ # Do not complain, so a configure script can configure whichever
+ # parts of a large source tree are present.
diff --git a/security/ssh2/files/patch-ac b/security/ssh2/files/patch-ac
index 3ae8d807cdc1..d5e9bf2a4dac 100644
--- a/security/ssh2/files/patch-ac
+++ b/security/ssh2/files/patch-ac
@@ -1,23 +1,184 @@
-*** gmp-2.0.2/Makefile.in.bak Mon Sep 30 02:29:39 1996
---- gmp-2.0.2/Makefile.in Wed Oct 16 07:33:48 1996
+*** Makefile.in.old Tue Oct 22 02:26:19 1996
+--- Makefile.in Tue Oct 22 02:30:18 1996
***************
-*** 27,35 ****
- infodir = $(prefix)/info
- includedir = $(prefix)/include
-
-! CC = gcc
- LOCAL_CC = $(CC)
-! CFLAGS = -g -O
- XCFLAGS =
- AR = ar
- AR_FLAGS = rc
---- 27,35 ----
- infodir = $(prefix)/info
- includedir = $(prefix)/include
-
-! #CC = gcc
- LOCAL_CC = $(CC)
-! #CFLAGS = -g -O
- XCFLAGS =
- AR = ar
- AR_FLAGS = rc
+*** 159,170 ****
+ SHELL = /bin/sh
+
+ GMPDIR = gmp-2.0.2
+! GMPLIBS = -L$(GMPDIR) -lgmp
+! GMPDEP = $(GMPDIR)/gmp.h $(GMPDIR)/libgmp.a
+
+ ZLIBDIR = zlib-1.0.3
+! ZLIBDEP = $(ZLIBDIR)/libz.a
+! ZLIBLIBS = -L$(ZLIBDIR) -lz
+
+ RSAREFDIR = rsaref2
+ RSAREFSRCDIR = $(RSAREFDIR)/source
+--- 159,176 ----
+ SHELL = /bin/sh
+
+ GMPDIR = gmp-2.0.2
+! # We have the same libgmp in the system, so use it instead
+! GMPINCDIR = /usr/include
+! GMPLIBDIR = /usr/lib
+! GMPDEP = $(GMPINCDIR)/gmp.h $(GMPLIBDIR)/libgmp.a
+! GMPLIBS = -L$(GMPLIBDIR) -lgmp
+
+ ZLIBDIR = zlib-1.0.3
+! # We have newer libz in the system, so use it instead
+! ZLIBINCDIR = /usr/include
+! ZLIBLIBDIR = /usr/lib
+! ZLIBDEP = $(ZLIBINCDIR)/zlib.h $(ZLIBLIBDIR)/libz.a
+! ZLIBLIBS = -L$(ZLIBLIBDIR) -lz
+
+ RSAREFDIR = rsaref2
+ RSAREFSRCDIR = $(RSAREFDIR)/source
+***************
+*** 248,254 ****
+ $(CC) -o rfc-pg rfc-pg.c
+
+ .c.o:
+! $(CC) -c -I. -I$(srcdir)/$(GMPDIR) -I$(srcdir)/$(ZLIBDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DBINDIR=\"$(bindir)\" $(CFLAGS) $(X_CFLAGS) $<
+
+ sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
+ -rm -f sshd
+--- 254,260 ----
+ $(CC) -o rfc-pg rfc-pg.c
+
+ .c.o:
+! $(CC) -c -I. -I$(GMPINCDIR) -I$(ZLIBINCDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DBINDIR=\"$(bindir)\" $(CFLAGS) $(X_CFLAGS) $<
+
+ sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
+ -rm -f sshd
+***************
+*** 292,310 ****
+ ./gen_minfd $(USER_SHELLS) > minfd.h~
+ mv -f minfd.h~ minfd.h
+
+! GMP_COPY_SOURCES = mpz_gcd.c mpz_powm.c mpz_pow_ui.c mpz_add.c mpz_sub.c \
+! mpz_mul.c mpz_cmp.c mpz_sqrtrem.c
+! $(GMPDIR)/libgmp.a:
+! cd $(GMPDIR); $(MAKE)
+!
+! $(ZLIBDEP):
+! -if test '!' -d $(ZLIBDIR); then \
+! mkdir $(ZLIBDIR); \
+! cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
+! fi
+! cd $(ZLIBDIR); $(MAKE) VPATH=$(srcdir)/$(ZLIBDIR):../$(srcdir)/$(ZLIBDIR) \
+! CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(ZLIBDIR) \
+! -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)" libz.a
+
+ $(RSAREFSRCDIR)/librsaref.a:
+ -if test '!' -d $(RSAREFDIR); then \
+--- 298,316 ----
+ ./gen_minfd $(USER_SHELLS) > minfd.h~
+ mv -f minfd.h~ minfd.h
+
+! #GMP_COPY_SOURCES = mpz_gcd.c mpz_powm.c mpz_pow_ui.c mpz_add.c mpz_sub.c \
+! # mpz_mul.c mpz_cmp.c mpz_sqrtrem.c
+! #$(GMPDIR)/libgmp.a:
+! # cd $(GMPDIR); $(MAKE)
+!
+! #$(ZLIBDIR)/libz.a:
+! # -if test '!' -d $(ZLIBDIR); then \
+! # mkdir $(ZLIBDIR); \
+! # cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
+! # fi
+! # cd $(ZLIBDIR); $(MAKE) VPATH=$(srcdir)/$(ZLIBDIR):../$(srcdir)/$(ZLIBDIR) \
+! # CC="$(CC)" CFLAGS="$(CFLAGS) -I. -I$(srcdir)/$(ZLIBDIR) \
+! # -I../$(srcdir)/$(GMPDIR)" RANLIB="$(RANLIB)" libz.a
+
+ $(RSAREFSRCDIR)/librsaref.a:
+ -if test '!' -d $(RSAREFDIR); then \
+***************
+*** 361,367 ****
+ # (otherwise it can only log in as the user it runs as, and must be
+ # bound to a non-privileged port). Also, password authentication may
+ # not be available if non-root and using shadow passwords.
+! install: $(PROGRAMS) make-dirs generate-host-key install-configs
+ $(INSTALL_PROGRAM) -o root -m 04711 ssh $(install_prefix)$(bindir)/ssh
+ -if test "`echo ssh | sed '$(transform)'`" '!=' ssh; then \
+ rm -f $(install_prefix)$(bindir)/`echo ssh | sed '$(transform)'`; \
+--- 367,373 ----
+ # (otherwise it can only log in as the user it runs as, and must be
+ # bound to a non-privileged port). Also, password authentication may
+ # not be available if non-root and using shadow passwords.
+! install: $(PROGRAMS) make-dirs install-configs
+ $(INSTALL_PROGRAM) -o root -m 04711 ssh $(install_prefix)$(bindir)/ssh
+ -if test "`echo ssh | sed '$(transform)'`" '!=' ssh; then \
+ rm -f $(install_prefix)$(bindir)/`echo ssh | sed '$(transform)'`; \
+***************
+*** 462,488 ****
+
+ clean:
+ -rm -f *.o minfd.h gmon.out *core $(PROGRAMS) gen_minfd rfc-pg
+! cd $(GMPDIR); $(MAKE) clean
+ # cd $(RSAREFSRCDIR); rm -f *.o *.a
+! cd $(ZLIBDIR); $(MAKE) clean
+
+ distclean: clean
+ -rm -f Makefile config.status config.cache config.log config.h
+ -rm -f ssh.1 sshd.8 make-ssh-known-hosts.1
+! cd $(GMPDIR); $(MAKE) distclean
+! cd $(ZLIBDIR); $(MAKE) distclean
+
+ dist:
+ -rm -rf $(DISTNAME)
+ -mkdir $(DISTNAME)
+ cp $(DISTFILES) $(DISTNAME)
+ -rm $(DISTNAME)/config.h
+! tar cf - $(GMPDIR) | (cd $(DISTNAME); tar xf -)
+! cd $(DISTNAME)/$(GMPDIR); $(MAKE) clean
+ # tar cf - $(RSAREFDIR) | (cd $(DISTNAME); tar xf -)
+ # cd $(DISTNAME)/$(RSAREFSRCDIR); rm -f *.o *.a
+! tar cf - $(ZLIBDIR) | (cd $(DISTNAME); tar xf -)
+! cd $(DISTNAME)/$(ZLIBDIR); rm -f *.o *.a
+ tar cf $(DISTNAME).tar $(DISTNAME)
+ -rm -f $(DISTNAME).tar.gz
+ gzip $(DISTNAME).tar
+--- 468,494 ----
+
+ clean:
+ -rm -f *.o minfd.h gmon.out *core $(PROGRAMS) gen_minfd rfc-pg
+! # cd $(GMPDIR); $(MAKE) clean
+ # cd $(RSAREFSRCDIR); rm -f *.o *.a
+! # cd $(ZLIBDIR); $(MAKE) clean
+
+ distclean: clean
+ -rm -f Makefile config.status config.cache config.log config.h
+ -rm -f ssh.1 sshd.8 make-ssh-known-hosts.1
+! # cd $(GMPDIR); $(MAKE) distclean
+! # cd $(ZLIBDIR); $(MAKE) distclean
+
+ dist:
+ -rm -rf $(DISTNAME)
+ -mkdir $(DISTNAME)
+ cp $(DISTFILES) $(DISTNAME)
+ -rm $(DISTNAME)/config.h
+! # tar cf - $(GMPDIR) | (cd $(DISTNAME); tar xf -)
+! # cd $(DISTNAME)/$(GMPDIR); $(MAKE) clean
+ # tar cf - $(RSAREFDIR) | (cd $(DISTNAME); tar xf -)
+ # cd $(DISTNAME)/$(RSAREFSRCDIR); rm -f *.o *.a
+! # tar cf - $(ZLIBDIR) | (cd $(DISTNAME); tar xf -)
+! # cd $(DISTNAME)/$(ZLIBDIR); rm -f *.o *.a
+ tar cf $(DISTNAME).tar $(DISTNAME)
+ -rm -f $(DISTNAME).tar.gz
+ gzip $(DISTNAME).tar
+***************
+*** 494,500 ****
+ (echo "s/\.$$old_version\"/.$$new_version\"/g"; echo w; echo q) | ed version.h >/dev/null
+
+ depend:
+! $(MAKEDEP) -I$(srcdir) -I. -I$(GMPDIR) -I$(ZLIBDIR) $(DEFS) $(SRCS)
+
+ tags:
+ find config.h $(srcdir) -name '*.[chly]' -print | xargs etags -a
+--- 500,506 ----
+ (echo "s/\.$$old_version\"/.$$new_version\"/g"; echo w; echo q) | ed version.h >/dev/null
+
+ depend:
+! $(MAKEDEP) -I$(srcdir) -I. $(DEFS) $(SRCS)
+
+ tags:
+ find config.h $(srcdir) -name '*.[chly]' -print | xargs etags -a
diff --git a/security/ssh2/files/patch-af b/security/ssh2/files/patch-af
deleted file mode 100644
index bdeef63301f8..000000000000
--- a/security/ssh2/files/patch-af
+++ /dev/null
@@ -1,67 +0,0 @@
-*** Makefile.in.orig Fri Oct 4 17:00:43 1996
---- Makefile.in Wed Oct 16 06:40:44 1996
-***************
-*** 159,170 ****
- SHELL = /bin/sh
-
- GMPDIR = gmp-2.0.2
-! GMPLIBS = -L$(GMPDIR) -lgmp
-! GMPDEP = $(GMPDIR)/gmp.h $(GMPDIR)/libgmp.a
-
- ZLIBDIR = zlib-1.0.3
-! ZLIBDEP = $(ZLIBDIR)/libz.a
-! ZLIBLIBS = -L$(ZLIBDIR) -lz
-
- RSAREFDIR = rsaref2
- RSAREFSRCDIR = $(RSAREFDIR)/source
---- 159,174 ----
- SHELL = /bin/sh
-
- GMPDIR = gmp-2.0.2
-! GMPINCDIR = $(GMPDIR)
-! GMPLIBDIR = $(GMPDIR)
-! GMPDEP = $(GMPINCDIR)/gmp.h $(GMPLIBDIR)/libgmp.a
-! GMPLIBS = -L$(GMPLIBDIR) -lgmp
-
- ZLIBDIR = zlib-1.0.3
-! ZLIBINCDIR = $(ZLIBDIR)
-! ZLIBLIBDIR = $(ZLIBDIR)
-! ZLIBDEP = $(ZLIBINCDIR)/zlib.h $(ZLIBLIBDIR)/libz.a
-! ZLIBLIBS = -L$(ZLIBLIBDIR) -lz
-
- RSAREFDIR = rsaref2
- RSAREFSRCDIR = $(RSAREFDIR)/source
-***************
-*** 248,254 ****
- $(CC) -o rfc-pg rfc-pg.c
-
- .c.o:
-! $(CC) -c -I. -I$(srcdir)/$(GMPDIR) -I$(srcdir)/$(ZLIBDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DBINDIR=\"$(bindir)\" $(CFLAGS) $(X_CFLAGS) $<
-
- sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
- -rm -f sshd
---- 252,258 ----
- $(CC) -o rfc-pg rfc-pg.c
-
- .c.o:
-! $(CC) -c -I. -I$(GMPINCDIR) -I$(ZLIBINCDIR) $(DEFS) -DHOST_KEY_FILE=\"$(HOST_KEY_FILE)\" -DHOST_CONFIG_FILE=\"$(HOST_CONFIG_FILE)\" -DSERVER_CONFIG_FILE=\"$(SERVER_CONFIG_FILE)\" -DSSH_PROGRAM=\"$(SSH_PROGRAM)\" -DETCDIR=\"$(etcdir)\" -DPIDDIR=\"$(piddir)\" -DBINDIR=\"$(bindir)\" $(CFLAGS) $(X_CFLAGS) $<
-
- sshd: $(SSHD_OBJS) $(GMPDEP) $(RSAREFDEP) $(ZLIBDEP)
- -rm -f sshd
-***************
-*** 297,303 ****
- $(GMPDIR)/libgmp.a:
- cd $(GMPDIR); $(MAKE)
-
-! $(ZLIBDEP):
- -if test '!' -d $(ZLIBDIR); then \
- mkdir $(ZLIBDIR); \
- cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
---- 301,307 ----
- $(GMPDIR)/libgmp.a:
- cd $(GMPDIR); $(MAKE)
-
-! $(ZLIBDIR)/libz.a:
- -if test '!' -d $(ZLIBDIR); then \
- mkdir $(ZLIBDIR); \
- cp $(srcdir)/$(ZLIBDIR)/Makefile $(ZLIBDIR); \
diff --git a/security/ssh2/files/patch-aj b/security/ssh2/files/patch-aj
index b20aab8e19f8..1412e9d6a522 100644
--- a/security/ssh2/files/patch-aj
+++ b/security/ssh2/files/patch-aj
@@ -13,18 +13,3 @@
AC_MSG_CHECKING([that the compiler works])
AC_TRY_RUN([ main(int ac, char **av) { return 0; } ],
---- configure.dist Wed Aug 7 13:45:37 1996
-+++ configure Wed Aug 7 13:55:29 1996
-@@ -1274,12 +1274,6 @@
- ;;
- esac
-
--# Socket pairs appear to be broken on several systems. I don't know exactly
--# where, so I'll use pipes everywhere for now.
--cat >> confdefs.h <<\EOF
--#define USE_PIPES 1
--EOF
--
-
- echo $ac_n "checking that the compiler works""... $ac_c" 1>&6
- if test "$cross_compiling" = yes; then