aboutsummaryrefslogtreecommitdiff
path: root/security/ssh
diff options
context:
space:
mode:
Diffstat (limited to 'security/ssh')
-rw-r--r--security/ssh/Makefile2
-rw-r--r--security/ssh/files/patch-ay2
2 files changed, 2 insertions, 2 deletions
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index cd1cae108e01..11e4183e0704 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -10,7 +10,7 @@
PORTNAME= ssh
PORTVERSION= 1.2.27 # Note, 1.2.30 is under a more restrictive license
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.cs.engr.uky.edu/cs/software/ \
ftp://ftp.cs.umn.edu/dept/users/rybski/ \
diff --git a/security/ssh/files/patch-ay b/security/ssh/files/patch-ay
index 51e949e323e3..71daac2ca4a9 100644
--- a/security/ssh/files/patch-ay
+++ b/security/ssh/files/patch-ay
@@ -10,7 +10,7 @@
+ if (time(NULL) - last_kill_time > 60 && getppid() != 1)
+ {
+ last_kill_time = time(NULL);
-+ kill(SIGALRM, getppid());
++ kill(getppid(), SIGALRM);
+ }
+ fatal("Bad result from rsa_private_decrypt");
+ }