aboutsummaryrefslogtreecommitdiff
path: root/security/sshblock
diff options
context:
space:
mode:
Diffstat (limited to 'security/sshblock')
-rw-r--r--security/sshblock/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/security/sshblock/Makefile b/security/sshblock/Makefile
index b243ca0d8fab..a24ac4fb1408 100644
--- a/security/sshblock/Makefile
+++ b/security/sshblock/Makefile
@@ -16,25 +16,21 @@ RUN_DEPENDS= p5-File-Tail>=0:${PORTSDIR}/devel/p5-File-Tail
NO_BUILD= yes
NO_WRKSUBDIR= yes
PLIST_FILES= sbin/sshblock
-USES= perl5
+USES= perl5 shebangfix
USE_RC_SUBR= sshblock
SUB_LIST= PERL=${PERL}
EXTRACT_CMD= ${CP}
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= ${WRKDIR}
SUB_FILES+= pkg-message
-#SUB_FILES= sshblock.sh
+SHEBANG_FILES= ${WRKSRC}/sshblock-${PORTVERSION}.pl
-NO_STAGE= yes
do-patch:
@${REINPLACE_CMD} -e "s@/usr/bin/perl@${PERL}@" \
${WRKSRC}/sshblock-${PORTVERSION}.pl
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/sshblock-${PORTVERSION}.pl \
- ${PREFIX}/sbin/sshblock
-
-post-install:
- ${CAT} ${PKGMESSAGE}
+ ${STAGEDIR}${PREFIX}/sbin/sshblock
.include <bsd.port.mk>