aboutsummaryrefslogtreecommitdiff
path: root/security/sssd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/sssd/Makefile')
-rw-r--r--security/sssd/Makefile67
1 files changed, 32 insertions, 35 deletions
diff --git a/security/sssd/Makefile b/security/sssd/Makefile
index 7a9b0e089ec0..480f9ab6c69b 100644
--- a/security/sssd/Makefile
+++ b/security/sssd/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= sssd
-PORTVERSION= 1.11.7
-PORTREVISION= 22
+PORTVERSION= 1.16.5
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= https://releases.pagure.org/SSSD/${PORTNAME}/
@@ -13,14 +13,11 @@ COMMENT= System Security Services Daemon
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-DEPRECATED= Uses deprecated version of python
-EXPIRATION_DATE= 2020-09-15
-
LIB_DEPENDS= libpopt.so:devel/popt \
libtalloc.so:devel/talloc \
libtevent.so:devel/tevent \
libtdb.so:databases/tdb \
- libldb.so:databases/ldb14 \
+ libldb.so:databases/ldb21 \
libcares.so:dns/c-ares \
libdbus-1.so:devel/dbus \
libdhash.so:devel/ding-libs \
@@ -37,33 +34,37 @@ BUILD_DEPENDS= xmlcatalog:textproc/libxml2 \
krb5>=1.10:security/krb5 \
nsupdate:dns/bind-tools
-USES= autoreconf cpe gettext gmake iconv libtool pathfix pkgconfig \
- python:2.7 shebangfix gssapi:mit
-
-USE_LDCONFIG= yes
-USE_OPENLDAP= yes
-
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-selinux=no --with-semanage=no \
+CONFIGURE_ARGS= --without-selinux --without-semanage \
+ --without-libnl --without-nfsv4-idmapd-plugin \
+ --without-autofs --without-secrets --without-kcm \
+ --without-python2-bindings \
+ --with-init-dir=no \
+ --disable-cifs-idmap-plugin \
+ --with-unicode-lib=libunistring \
--with-ldb-lib-dir=${LOCALBASE}/lib/shared-modules/ldb \
--with-xml-catalog-path=${LOCALBASE}/share/xml/catalog \
- --with-libnl=no --with-init-dir=no --datadir=${DATADIR} \
- --docdir=${DOCSDIR} --with-pid-path=/var/run \
- --localstatedir=/var --enable-pammoddir=${PREFIX}/lib \
- --with-db-path=/var/db/sss --with-pipe-path=/var/run/sss \
- --with-pubconf-path=/var/run/sss --with-mcache-path=/var/db/sss_mc \
- --with-unicode-lib=libunistring --with-autofs=no \
- --disable-cifs-idmap-plugin --disable-config-lib \
- --with-krb5-conf=/etc/krb5.conf
+ --datadir=${DATADIR} --docdir=${DOCSDIR} --localstatedir=/var \
+ --with-db-path=/var/db/sss/db --with-mcache-path=/var/db/sss/mc \
+ --with-pubconf-path=/var/db/sss/pubconf \
+ --with-gpo-cache-path=/var/db/sss/gpo_cache \
+ --with-pid-path=/var/run --with-pipe-path=/var/run/sss/pipes \
+ --with-krb5-conf=/etc/krb5.conf \
+ --enable-pammoddir=${PREFIX}/lib
CFLAGS+= -fstack-protector-all
PLIST_SUB= PYTHON_VER=${PYTHON_VER}
#DEBUG_FLAGS= -g
MAKE_ENV+= LINGUAS="bg de eu es fr hu id it ja nb nl pl pt ru sv tg tr uk zh_CN zh_TW"
SUB_FILES= pkg-message
+USES= autoreconf cpe gettext gmake iconv libtool pathfix pkgconfig \
+ python:3.7 shebangfix gssapi:mit
+USE_LDCONFIG= yes
+USE_OPENLDAP= yes
INSTALL_TARGET= install-strip
CPE_VENDOR= fedoraproject
+BINARY_ALIAS= python3=python${PYTHON_VER}
SHEBANG_FILES= src/tools/sss_obfuscate \
src/sbus/sbus_codegen
@@ -73,18 +74,17 @@ PORTDATA= *
OPTIONS_DEFINE= DOCS SMB
OPTIONS_SUB= yes
-# If the port fails to package with SMB=on due to some missing files from
-# pkg-plist, check if there was a version bump of security/krb5 and
-# update files/patch-src__external__krb5.m4 accordingly.
-#
-# See: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=244778
-
SMB_DESC= Install IPA and AD providers (requires Samba4)
-SMB_USES= samba:lib # libndr-krb5pac libndr-nbt libndr libsamba-util
-SMB_CONFIGURE_WITH= samba
+SMB_USES= samba:lib
+SMB_CONFIGURE_WITH= samba smb-idmap-interface-version=6
+SMB_LIB_DEPENDS= libndr-nbt.so.0:net/samba412 \
+ libndr-krb5pac.so.0:net/samba412 \
+ libndr-standard.so.0:net/samba412 \
+ libndr.so.1:net/samba412 \
+ libsamba-util.so.0:net/samba412 \
+ libsmbclient.so.0:net/samba412
post-patch:
- @${REINPLACE_CMD} -e 's|SIGCLD|SIGCHLD|g' ${WRKSRC}/src/util/signal.c
@${REINPLACE_CMD} -e 's|NSS_STATUS_NOTFOUND|NS_NOTFOUND|g' \
-e 's|NSS_STATUS_UNAVAIL|NS_UNAVAIL|g' \
-e 's|NSS_STATUS_TRYAGAIN|NS_TRYAGAIN|g' \
@@ -108,12 +108,9 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/src/examples/sssd-example.conf \
${STAGEDIR}${ETCDIR}/sssd.conf.sample
${LN} -sf nss_sss.so ${STAGEDIR}${PREFIX}/lib/nss_sss.so.1
-# clean these up from the install; we create them in rc script start_precmd
-.for d in db/sss db/sss_mc log/sssd run/sss/krb5.include.d run/sss/private run/sss
- @${RMDIR} ${STAGEDIR}/var/${d}
-.endfor
+
# clean unused man dirs
-.for i in nl/man1 nl/man5 pt/man1 pt/man5
+.for i in es/man1 nl/man1 nl/man5 pt/man1 pt/man5 sv/man1
@${RMDIR} ${STAGEDIR}${PREFIX}/man/${i}
.endfor