aboutsummaryrefslogtreecommitdiff
path: root/security/strongswan
diff options
context:
space:
mode:
Diffstat (limited to 'security/strongswan')
-rw-r--r--security/strongswan/Makefile2
-rw-r--r--security/strongswan/files/patch-src_libcharon_sa_ikev2_authenticators_pubkey_authenticator.c22
2 files changed, 24 insertions, 0 deletions
diff --git a/security/strongswan/Makefile b/security/strongswan/Makefile
index a2f8f02d2b56..1dad5cadc468 100644
--- a/security/strongswan/Makefile
+++ b/security/strongswan/Makefile
@@ -3,6 +3,7 @@
PORTNAME= strongswan
PORTVERSION= 5.6.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://download.strongswan.org/ \
http://download2.strongswan.org/
@@ -11,6 +12,7 @@ MAINTAINER= strongswan@nanoteq.com
COMMENT= Open Source IKEv2 IPsec-based VPN solution
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cpe libtool:keepla pkgconfig tar:bzip2 ssl
USE_RC_SUBR= strongswan
diff --git a/security/strongswan/files/patch-src_libcharon_sa_ikev2_authenticators_pubkey_authenticator.c b/security/strongswan/files/patch-src_libcharon_sa_ikev2_authenticators_pubkey_authenticator.c
new file mode 100644
index 000000000000..722a2b8ceb0b
--- /dev/null
+++ b/security/strongswan/files/patch-src_libcharon_sa_ikev2_authenticators_pubkey_authenticator.c
@@ -0,0 +1,22 @@
+--- src/libcharon/sa/ikev2/authenticators/pubkey_authenticator.c.orig
++++ src/libcharon/sa/ikev2/authenticators/pubkey_authenticator.c
+@@ -164,7 +164,7 @@ static array_t *select_signature_schemes(keymat_v2_t *keymat,
+ signature_scheme_t schemes[] = {
+ SIGN_RSA_EMSA_PKCS1_SHA2_384,
+ SIGN_RSA_EMSA_PKCS1_SHA2_256,
+- }, contained;
++ };
+ bool found;
+ int i, j;
+
+@@ -174,8 +174,8 @@ static array_t *select_signature_schemes(keymat_v2_t *keymat,
+ found = FALSE;
+ for (j = 0; j < array_count(selected); j++)
+ {
+- array_get(selected, j, &contained);
+- if (scheme == contained)
++ array_get(selected, j, &config);
++ if (scheme == config->scheme)
+ {
+ found = TRUE;
+ break;