aboutsummaryrefslogtreecommitdiff
path: root/security/strongswan
diff options
context:
space:
mode:
Diffstat (limited to 'security/strongswan')
-rw-r--r--security/strongswan/Makefile21
-rw-r--r--security/strongswan/distinfo4
-rw-r--r--security/strongswan/files/patch-conf__Makefile.in12
-rw-r--r--security/strongswan/files/patch-src__libhydra__plugins__kernel_pfroute__kernel_pfroute_net.c13
-rw-r--r--security/strongswan/pkg-plist54
5 files changed, 44 insertions, 60 deletions
diff --git a/security/strongswan/Makefile b/security/strongswan/Makefile
index 98d111a86181..812c3ad05d47 100644
--- a/security/strongswan/Makefile
+++ b/security/strongswan/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= strongswan
-PORTVERSION= 5.2.0
-PORTREVISION= 1
+PORTVERSION= 5.2.1
CATEGORIES= security
MASTER_SITES= http://download.strongswan.org/ \
http://download2.strongswan.org/
@@ -11,9 +10,7 @@ MASTER_SITES= http://download.strongswan.org/ \
MAINTAINER= strongswan@nanoteq.com
COMMENT= Open Source IKEv2 IPsec-based VPN solution
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
-
-USES= libtool:keepla tar:bzip2
+USES= execinfo libtool:keepla tar:bzip2
USE_OPENSSL= yes
USE_RC_SUBR= strongswan
GNU_CONFIGURE= yes
@@ -41,8 +38,8 @@ CONFIGURE_ARGS= --enable-kernel-pfkey \
--with-lib-prefix=${PREFIX}
OPTIONS_DEFINE= CURL EAPAKA3GPP2 EAPDYNAMIC EAPRADIUS EAPSIMFILE IKEv1 \
- IPSECKEY KERNELLIBIPSEC LOADTESTER LDAP MYSQL SQLITE \
- TESTVECTOR TOOLS UNBOUND XAUTH
+ IPSECKEY KERNELLIBIPSEC LOADTESTER LDAP MYSQL PKI SCEP SQLITE \
+ TESTVECTOR UNBOUND XAUTH
OPTIONS_SUB= yes
CURL_DESC= Enable CURL to fetch CRL/OCSP
EAPAKA3GPP2_DESC= Enable EAP AKA with 3gpp2 backend
@@ -54,7 +51,8 @@ IPSECKEY_DESC= Enable authentication with IPSECKEY resource records with DNSSEC
KERNELLIBIPSEC_DESC= Enable IPSec userland backend
LOADTESTER_DESC= Enable load testing plugin
TESTVECTOR_DESC= Enable crypto test vectors
-TOOLS_DESC= Enable PKI tools
+PKI_DESC= Enable PKI tools
+SCEP_DESC= Enable Simple Certificate Enrollment Protocol
UNBOUND_DESC= Enable DNSSEC-enabled resolver
XAUTH_DESC= Enable XAuth password verification
@@ -71,13 +69,14 @@ IPSECKEY_CONFIGURE_ON= --enable-ipseckey
KERNELLIBIPSEC_CONFIGURE_ON= --enable-kernel-libipsec
LOADTESTER_CONFIGURE_ON=--enable-load-tester
LDAP_CONFIGURE_ON= --enable-ldap
-LDAP_USE= USE_OPENLDAP=yes
+LDAP_USE= OPENLDAP=yes
MYSQL_CONFIGURE_ON= --enable-mysql
-MYSQL_USE= USE_MYSQL=yes
+MYSQL_USE= MYSQL=yes
SQLITE_CONFIGURE_ON= --enable-sqlite
SQLITE_LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3
TESTVECTOR_CONFIGURE_ON=--enable-test-vectors
-TOOLS_CONFIGURE_OFF= --disable-tools
+PKI_CONFIGURE_OFF= --disable-pki
+SCEP_CONFIGURE_OFF= --disable-scepclient
UNBOUND_CONFIGURE_ON= --enable-unbound
UNBOUND_LIB_DEPENDS= libunbound.so:${PORTSDIR}/dns/unbound
XAUTH_CONFIGURE_ON= --enable-xauth-eap --enable-xauth-generic
diff --git a/security/strongswan/distinfo b/security/strongswan/distinfo
index 1db57467d3b2..661e424e4198 100644
--- a/security/strongswan/distinfo
+++ b/security/strongswan/distinfo
@@ -1,2 +1,2 @@
-SHA256 (strongswan-5.2.0.tar.bz2) = b00c30bd2e60ff2e5fc85f54bbad54fe246585812fdf212dbe777a5258da26ce
-SIZE (strongswan-5.2.0.tar.bz2) = 4063992
+SHA256 (strongswan-5.2.1.tar.bz2) = ea51ab33b5bb39fecaf10668833a9936583b42145948ae9da1ab98f74e939215
+SIZE (strongswan-5.2.1.tar.bz2) = 4075576
diff --git a/security/strongswan/files/patch-conf__Makefile.in b/security/strongswan/files/patch-conf__Makefile.in
index ce39061a91d4..085193710bee 100644
--- a/security/strongswan/files/patch-conf__Makefile.in
+++ b/security/strongswan/files/patch-conf__Makefile.in
@@ -1,9 +1,9 @@
---- ./conf/Makefile.in.orig 2014-07-08 16:06:08.000000000 +0200
-+++ ./conf/Makefile.in 2014-08-19 09:48:46.000000000 +0200
-@@ -842,15 +842,15 @@
- test -e "$(DESTDIR)${strongswanconfdir}" || $(INSTALL) -d "$(DESTDIR)$(strongswanconfdir)"
- test -e "$(DESTDIR)${strongswanddir}" || $(INSTALL) -d "$(DESTDIR)$(strongswanddir)"
- test -e "$(DESTDIR)${charonconfdir}" || $(INSTALL) -d "$(DESTDIR)$(charonconfdir)"
+--- conf/Makefile.in.orig 2014-10-18 08:23:39 UTC
++++ conf/Makefile.in
+@@ -852,15 +852,15 @@
+ test -e "$(DESTDIR)${strongswanconfdir}" || $(INSTALL) -d "$(DESTDIR)$(strongswanconfdir)" || true
+ test -e "$(DESTDIR)${strongswanddir}" || $(INSTALL) -d "$(DESTDIR)$(strongswanddir)" || true
+ test -e "$(DESTDIR)${charonconfdir}" || $(INSTALL) -d "$(DESTDIR)$(charonconfdir)" || true
- test -e "$(DESTDIR)$(strongswanconfdir)/strongswan.conf" || $(INSTALL) -m 644 $(srcdir)/strongswan.conf $(DESTDIR)$(strongswanconfdir)/strongswan.conf || true
+ test -e "$(DESTDIR)$(strongswanconfdir)/strongswan.conf" || $(INSTALL) -m 644 $(srcdir)/strongswan.conf $(DESTDIR)$(strongswanconfdir)/strongswan.conf.sample || true
for f in $(options_install_src); do \
diff --git a/security/strongswan/files/patch-src__libhydra__plugins__kernel_pfroute__kernel_pfroute_net.c b/security/strongswan/files/patch-src__libhydra__plugins__kernel_pfroute__kernel_pfroute_net.c
deleted file mode 100644
index 793386658c4d..000000000000
--- a/security/strongswan/files/patch-src__libhydra__plugins__kernel_pfroute__kernel_pfroute_net.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./src/libhydra/plugins/kernel_pfroute/kernel_pfroute_net.c.orig 2014-06-26 09:10:00.000000000 +0200
-+++ ./src/libhydra/plugins/kernel_pfroute/kernel_pfroute_net.c 2014-08-19 09:48:46.000000000 +0200
-@@ -1518,8 +1518,8 @@
- { /* timed out? */
- break;
- }
-- if (this->reply->rtm_msglen < sizeof(*this->reply) ||
-- msg.hdr.rtm_seq != this->reply->rtm_seq)
-+ if ((this->reply == 0) || (this->reply->rtm_msglen < sizeof(*this->reply) ||
-+ msg.hdr.rtm_seq != this->reply->rtm_seq))
- {
- continue;
- }
diff --git a/security/strongswan/pkg-plist b/security/strongswan/pkg-plist
index 2a1291cd782e..bb9213d8d377 100644
--- a/security/strongswan/pkg-plist
+++ b/security/strongswan/pkg-plist
@@ -311,25 +311,25 @@ man/man8/_updown_espmark.8.gz
%%TESTVECTOR%%lib/ipsec/plugins/libstrongswan-test-vectors.so
%%TESTVECTOR%%%%DATADIR%%/templates/config/plugins/test-vectors.conf
%%TESTVECTOR%%@sample %%ETCDIR%%.d/charon/test-vectors.conf.sample
-%%TOOLS%%bin/pki
-%%TOOLS%%libexec/ipsec/scepclient
-%%TOOLS%%man/man1/pki---acert.1.gz
-%%TOOLS%%man/man1/pki---gen.1.gz
-%%TOOLS%%man/man1/pki---issue.1.gz
-%%TOOLS%%man/man1/pki---keyid.1.gz
-%%TOOLS%%man/man1/pki---pkcs7.1.gz
-%%TOOLS%%man/man1/pki---print.1.gz
-%%TOOLS%%man/man1/pki---pub.1.gz
-%%TOOLS%%man/man1/pki---req.1.gz
-%%TOOLS%%man/man1/pki---self.1.gz
-%%TOOLS%%man/man1/pki---signcrl.1.gz
-%%TOOLS%%man/man1/pki---verify.1.gz
-%%TOOLS%%man/man1/pki.1.gz
-%%TOOLS%%man/man8/scepclient.8.gz
-%%TOOLS%%%%DATADIR%%/templates/config/strongswan.d/pki.conf
-%%TOOLS%%@sample %%ETCDIR%%.d/pki.conf.sample
-%%TOOLS%%%%DATADIR%%/templates/config/strongswan.d/scepclient.conf
-%%TOOLS%%@sample %%ETCDIR%%.d/scepclient.conf.sample
+%%PKI%%bin/pki
+%%PKI%%man/man1/pki---acert.1.gz
+%%PKI%%man/man1/pki---gen.1.gz
+%%PKI%%man/man1/pki---issue.1.gz
+%%PKI%%man/man1/pki---keyid.1.gz
+%%PKI%%man/man1/pki---pkcs7.1.gz
+%%PKI%%man/man1/pki---print.1.gz
+%%PKI%%man/man1/pki---pub.1.gz
+%%PKI%%man/man1/pki---req.1.gz
+%%PKI%%man/man1/pki---self.1.gz
+%%PKI%%man/man1/pki---signcrl.1.gz
+%%PKI%%man/man1/pki---verify.1.gz
+%%PKI%%man/man1/pki.1.gz
+%%PKI%%%%DATADIR%%/templates/config/strongswan.d/pki.conf
+%%PKI%%@sample %%ETCDIR%%.d/pki.conf.sample
+%%SCEP%%libexec/ipsec/scepclient
+%%SCEP%%man/man8/scepclient.8.gz
+%%SCEP%%%%DATADIR%%/templates/config/strongswan.d/scepclient.conf
+%%SCEP%%@sample %%ETCDIR%%.d/scepclient.conf.sample
%%UNBOUND%%lib/ipsec/plugins/libstrongswan-unbound.a
%%UNBOUND%%lib/ipsec/plugins/libstrongswan-unbound.la
%%UNBOUND%%lib/ipsec/plugins/libstrongswan-unbound.so
@@ -393,13 +393,11 @@ lib/ipsec/libcharon.so.0.0.0
lib/ipsec/libhydra.so.0.0.0
lib/ipsec/libstrongswan.so.0.0.0
lib/ipsec/libtls.so.0.0.0
-@dir %%DATADIR%%/templates/config/plugins
-@dir lib/ipsec/plugins
-@dir etc/ipsec.d/reqs
-@dir etc/ipsec.d/private
-@dir etc/ipsec.d/ocspcerts
-@dir etc/ipsec.d/crls
-@dir etc/ipsec.d/certs
-@dir etc/ipsec.d/cacerts
-@dir etc/ipsec.d/acerts
@dir etc/ipsec.d/aacerts
+@dir etc/ipsec.d/acerts
+@dir etc/ipsec.d/cacerts
+@dir etc/ipsec.d/certs
+@dir etc/ipsec.d/crls
+@dir etc/ipsec.d/ocspcerts
+@dir etc/ipsec.d/private
+@dir etc/ipsec.d/reqs