aboutsummaryrefslogtreecommitdiff
path: root/security/sudo
diff options
context:
space:
mode:
Diffstat (limited to 'security/sudo')
-rw-r--r--security/sudo/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 77c2a28c26e8..114e6488d715 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -34,7 +34,10 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
OPTIONS= LDAP "With LDAP support" off \
INSULTS "With all insults" off \
- SHELL_SETS_HOME "Set HOME env to target user in shell mode" off
+ SHELL_SETS_HOME "Set HOME env to target user in shell mode" off \
+ DISABLE_ROOT_SUDO "Disable root sudo" off \
+ DISABLE_AUTH "Disable authentication" off \
+ NOARGS_SHELL "Enable no arguments shell" off
.include <bsd.port.pre.mk>
@@ -62,6 +65,18 @@ PLIST_SUB= LDAP="@comment "
CONFIGURE_ARGS+=--enable-shell-sets-home
.endif
+.if defined(WITH_DISABLE_ROOT_SUDO)
+CONFIGURE_ARGS+=--disable-root-sudo
+.endif
+
+.if defined(WITH_DISABLE_AUTH)
+CONFIGURE_ARGS+=--disable-authentication
+.endif
+
+.if defined(WITH_NOARGS_SHELL)
+CONFIGURE_ARGS+=--enable-noargs-shell
+.endif
+
MAN5= sudoers.5
MAN8= sudo.8 visudo.8
MLINKS= sudo.8 sudoedit.8